Computer hangs on radeon ati screen at startup - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 01-22-2006, 12:51 PM   #1 (permalink)
Junior Techie
Join Date: Oct 2004
Posts: 43
Default Computer hangs on radeon ati screen at startup

EDIT: I meant to put this in troubleshooting... sorry about that...

Basically it hangs for around 10 minutes at the start-up screen

"Graphics by ATI Radeon 9100 pro IGP
HT Ready"

and then after that it makes the usual clicking noises and eventually starts, but then hangs permanently (or at least for as long as I've left it - 20 minutes or so) at the windows startup screen, at which point I have to reset it (I think) and start windows using the last good configuration. If I hit f8 and do that first, I can avoid this, but I have to do it every time I restart the computer. Plus it's the initial ten minute wait that bothers me.

I never turn off my computer, because I'm worried I won't be able to get back on. Whenever I've had problems before, I've been advised to update the drivers, but I'm always getting the drivers from the same place (the cd that came with it), so I'm not sure if there's something else I'm supposed to be doing.

Basically before I restart again, I'd like to be sure I've done anything I need to.

Here are screenshots from CPU-Z and dxdiag. Is there any other information that would be helpful?


Dominic is offline  
Old 01-22-2006, 11:02 PM   #2 (permalink)
Junior Techie
Join Date: Nov 2005
Posts: 73
Send a message via Yahoo to coreyjames66

Here is a link to ATI's site. Follow the links and, it will take you to the driver updates page.

The drivers WERE updated recently (Jan. 18) so you most likely have out of date drivers.

************************************************** On the site it mentions this..........
"ATI recommends Windows XP Service Pack 2 or higher to be installed.

You must have Microsoft .NET Framework installed prior to downloading and installing the Catalyst Control Center "

Every time I've used an ATI video card I've had to find better drivers. Now, I don't even install what's on the cd. I go to their site and make sure I have the latest release.

Hope this helps,
We decide which is right and which is an illusion
coreyjames66 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:22 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.