AMD/ATi Catalyst 8.9 Drivers - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-18-2008, 09:59 AM   #11 (permalink)
Techie Beyond Description
 
veg1992's Avatar
 
Join Date: Dec 2006
Posts: 19,993
Default Re: AMD/ATi Catalyst 8.9 Drivers

It should take no more then a second....
__________________

__________________
I do not accept help requests and/or deleted threads/complaints by PM, Profile or IM/Email. Just ask on the forums! Also, I do have Lockerz invites if you want them, feel free to PM me your email if you want one :0

If I help you, or you just like what I said, rep me by clicking the
or under my avatar; it helps me know that my advice actually helped you.


.. But things don't go according to plan! My Actual Rig, 2009:
veg1992 is offline  
Old 09-18-2008, 10:03 AM   #12 (permalink)
Ultra Techie
 
Join Date: Dec 2007
Location: England
Posts: 605
Default Re: AMD/ATi Catalyst 8.9 Drivers

oh... well it deleted the files in a second( those 4 files and 4 registries i mentioned) but still tells me to wait and has done for 30+mins now, should i just click the red X and close it then?

Still i have a feeling this wont work, my card is doomed to have driver issues,lol. Why the ones on the disk wouldn't work is beyond me but it's not just freezing on Spore.
__________________

Joeyboy is offline  
Old 09-18-2008, 10:22 AM   #13 (permalink)
Lord Techie
 
veedubfreak's Avatar
 
Join Date: Jul 2007
Posts: 6,979
Default Re: AMD/ATi Catalyst 8.9 Drivers

If you are getting driver errors, it could also be that the card is overheating. But the random freezes in WoW went away with the 8.9s so i'm happy.
__________________
Nothing to see here.
veedubfreak is offline  
Old 09-18-2008, 10:56 AM   #14 (permalink)
Ultra Techie
 
Join Date: Dec 2007
Location: England
Posts: 605
Default Re: AMD/ATi Catalyst 8.9 Drivers

i doubt its overheating i did some fan speed change and it dropped from 65c idle to like 39c and now doesnt go above 60c i dont think.

lol just installed 8.9 again, installation seemed to go fine but now it cant find my card..
Joeyboy is offline  
Old 09-18-2008, 11:59 AM   #15 (permalink)
Ste
Do not Stare at my Avatar
 
Ste's Avatar
 
Join Date: Aug 2005
Location: Upon Gleaning Infinity
Posts: 9,577
Send a message via MSN to Ste
Default Re: AMD/ATi Catalyst 8.9 Drivers

Quote:
Originally Posted by Joeyboy View Post
ok you know driver cleaner pro, how long does it take generally? I've selected it to clean ATI and ATI CCC, i followed the instructions on the help file, i deleted ATI CCC from control panel and used control panel to uninstall drivers, now i am using this to clean whats left i guess.

It's deleted like 4 things and 4 registry things but still says "cleaning please wait!, its been like that for 30mins now with no more filed deleted or anything, is it finished but hasn't said so? Shall i just close it and try installed the 8.9 again?

Also does anyone know were to download drivers that are stable with vista 64-bit, the drivers that come with the card make my games freeze..

I'm sure it's a driver issue though, widows says on its crash reports it is and i increased the fan speed to 50% so it idles at 39c which is much cooler then it was before but it still freezes up.

It may help you to know the process in which I do to install new drivers for ATI cards.

Close out CCC or Hydravision
Remove CCC and Hydravision through add/remove programs
Remove driver for ATI card through device manager
Run Driver cleaner pro, select ATI, ATI CCC and ATI Hydravision, if it takes too long let it go for a minute and then end it manually.
Restart
Run driver cleaner pro again
Install new drivers with CCC.

has never failed me.
Ste is offline  
Old 09-18-2008, 01:02 PM   #16 (permalink)
Hellfire!
 
Wildside's Avatar
 
Join Date: Jan 2007
Location: Riverside, CA
Posts: 3,038
Send a message via MSN to Wildside
Default Re: AMD/ATi Catalyst 8.9 Drivers

i just installed the new ones, didnt uninstall the old ones. Got no problems, i dont see any improvement yet.

what are the bugs that get fixed? I dont have Adobe PDF reader yet.

EDIT:

copying this from a PC Gaming thread that i just wanted all of u to read:

Quote:
strange, i took out 1 512mb of RAM today to get 2.50GBs and my graphics card still shows that it is uses 2 x 256mb VRAM = 512mb?! WTF?! It suppose to be 1GB! Plus i dont get PCI-E 2.0 either. That is what i get for buying an early card..............sigh.....
ya strange isnt it?? Not true 1GB of VRAM and AMD Overdrive shows 2 x 256mb on each core. The second core operates at 300MHz, my first one at 825MHz too.
__________________
--Windows 10 Pro 64-Bit
--AMD Ryzen 1700x @ 3.4GHz w/ MX-4 and Corsair Hydro 100i Liquid Cooler
--Corsair LPX Vengeance Black 16GB (2 x 8GB) DDR4 3200 DRAM
--EVGA GeForce GTX 960 SuperSC ACX 2.0+ 2GB GDDR5
--ASUS Crosshair IV Hero AM4 X370 Motherboard
--WD BLACK SERIES WD2003FZEX 2TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" HDD
--SAMSUNG 840 EVO MZ-7TE250BW 2.5" 250GB SATA 6Gb/s SSD
--Corsair Obsidian 750D Black Aluminum / Steel ATX Full Tower Computer Case
--Corsair Professional Series 860-Watt AX860
Wildside is offline  
Old 09-18-2008, 01:09 PM   #17 (permalink)
Grandfather of Techist

¯\_(ツ)_/¯
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,302
Default Re: AMD/ATi Catalyst 8.9 Drivers

@ Joeyboy,

Give Omega Drivers a shot.
OmegaDrivers.net - Home of the ATI & NVIDIA Omega Drivers. Home
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 09-18-2008, 08:43 PM   #18 (permalink)
Lord Techie
 
ricanflow's Avatar
 
Join Date: Feb 2006
Location: Euless, Tx
Posts: 6,317
Default Re: AMD/ATi Catalyst 8.9 Drivers

Omega drivers hasnt updated drivers in almost a year. Hes working on new ones right now though.

Im still waiting for the new ATI ones cause my laptop needs them to run cod4.
__________________
3DMARK06 = 20,341 (3.8GHZ)



Laptop
P7350 | GTX 260M | 4GB DDR2 800 | 320GB HD | X-Fi | Vista 64

Folding Rig/File Server

M775 | E1200 | Foxconn P9657AB
| Dual 8800GT | Antec NeoHE 500 | Barracuda 80GB | Wintec Ampx



ricanflow is offline  
Old 09-22-2008, 11:12 AM   #19 (permalink)
Techie Beyond Description
 
Apokalipse's Avatar
 
Join Date: Jun 2003
Location: Melbourne, Australia
Posts: 14,559
Default Re: AMD/ATi Catalyst 8.9 Drivers

I'll often be installing Windows again every 1-3 months, so I can integrate the drivers into the install CD then

But other times, I'll go into C:\Windows\System32 (inluding the dllcache folders) (as well as SysWOW64 in my case), and manually delete the ATI driver files
__________________
Apokalipse is offline  
Old 09-22-2008, 09:40 PM   #20 (permalink)
Mod Emeritus
 
Puddle Jumper's Avatar
 
Join Date: Oct 2007
Posts: 4,286
Default Re: AMD/ATi Catalyst 8.9 Drivers

Does anyone know of any issues with the 8.9 drivers and Crysis Warhead. My brother went to run it on his new HD 4850 and the screen went to flickering white and black splotches. I though it was artifacting but aTi tool has been scanning for artifacts for 75 minutes now and has had no errors.
__________________

__________________

AMD Phenom II x4 955 Black Edition : Asus M4A89GTD PRO : Corsair 550VX
G.SKILL Ripjaws 4x2gb DDR3 1600 : MSI Geforce GTX 770 2gb : Antec 300
OCZ Agility 2 60gb SSD (OS) : SanDisk Ultra 120gb SSD (Apps) : Crucial M500 240gb (Steam) : Win 8.1 Pro 64bit
2x Samsung 2494LW & 1x Dell U2312HM Eyefinity

Lenovo ThinkPad X220 : Core i5 2410M : 12.5" 1366x768 IPS LED display : Intel 320 Series 120gb SSD

Samsung Galaxy Note 3 stock 4.3 : Nexus 7 2 stock 4.4

Puddle Jumper is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Catalyst 8.6 Drivers OUT! gurusan New Technology and Products 4 06-19-2008 04:09 PM
"Shoot Em Up" Catalyst drivers on the way Trotter New Systems | Building and Buying 7 10-12-2007 07:26 AM
Leaked ATI Catalyst 7.10 Beta Drivers Osiris Overclocking and Modding 0 09-23-2007 11:35 AM
Catalyst 7.9 Drivers Osiris Overclocking and Modding 2 09-12-2007 04:03 PM
Catalyst 7.8 Drivers Osiris Overclocking and Modding 0 08-13-2007 07:08 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.