x1950xt issues - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-02-2007, 08:29 PM   #1 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default x1950xt issues

When playing games, most noticably counter-strike: source, I notice some color distortions and I get some artifacting while at stock speeds and my fan on high.

Speaking of the fan, it was always very loud, but it seems to have developed an even louder and more irritating noise.

Any ideas? Should I contact sapphire for a replacement?
__________________

__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Old 07-02-2007, 08:32 PM   #2 (permalink)
Law
Wizard Techie
 
Law's Avatar
 
Join Date: Aug 2005
Location: the data closet
Posts: 4,200
Default Re: x1950xt issues

Sure dude if you can get a free replacement why not, sounds like the card is overheating. You might also double check your PSU. I don't think it's adequate for overclocking.
__________________

__________________

Law is offline  
Old 07-02-2007, 08:34 PM   #3 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default Re: x1950xt issues

Nah the card is running very cool actually. I bought a front fan for my case to pull in more air to the card, and i cranked up the fan speed and it's loading in the low 80's which is more than acceptable for an x1950xt.
__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Old 07-02-2007, 09:27 PM   #4 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default Re: x1950xt issues

Here are some pictures...

http://www.picgarage.net/images/cs_it_25633_480.jpeg
Normally they are thicker and more numerous, but this the first I could find. These are very common for me.

http://www.picgarage.net/images/cs_it_25699_120.jpeg
I get black spots like that every so often.

http://www.picgarage.net/images/cs_it_25733_831.jpeg
That also isn't uncommon for me, and it happens on a variety of guns.

http://www.picgarage.net/images/de_nu_25787_276.jpeg
http://www.picgarage.net/images/de_nu_25775_132.jpeg
I also get random, warped colors in weird places. This is extremely common and happens every single time I play.
__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Old 07-02-2007, 11:07 PM   #5 (permalink)
I know <html>, do you?
 
SYL\X/3K's Avatar
 
Join Date: Aug 2006
Location: 127.0.0.1
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K
Default Re: x1950xt issues

play around with ATI ccc , i had that too but i put everything on "let application decide" and it runs perfect
not sure about your fan , i was previously talked with someone and they said they're fan is loud too so im guessing its manufactured like that
__________________
P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Old 07-02-2007, 11:29 PM   #6 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default Re: x1950xt issues

Yeah I've tried that. And yeah the fan is loud, but I noticed today that the fan is getting to the point where i can hear it in another room. It sort of makes a squieling noise on occasion.

And I also just realized that if Sapphire does end up replacing or fixing me card I'm gonna have to wait about 4-8 weeks. I'm just gonna toss the thing away because I don't have a spare PCI-X card. This is the last time I bother with ATI.
__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Old 07-02-2007, 11:39 PM   #7 (permalink)
I know <html>, do you?
 
SYL\X/3K's Avatar
 
Join Date: Aug 2006
Location: 127.0.0.1
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K
Default Re: x1950xt issues

give it to me
this is why i go OEM
__________________
P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Old 07-02-2007, 11:41 PM   #8 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default Re: x1950xt issues

Well depending on if i can get these problems to get fixed slightly and the wait period on a replacement (if i get one).... i may end up holding onto it until the g90 is released. Still not sure, but what I'm sure about is that I'm done with ATI and I'm not happy with the x1950 series haha.
__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Old 07-04-2007, 02:25 AM   #9 (permalink)
Newb Techie
 
Join Date: Jun 2007
Posts: 12
Default Re: x1950xt issues

I've had an issue with temperature with the x1950XT, but it seems to be ok now, as you said 80C ish.

I used to get those black squares bit in red with my old nVidia 6200, I assumed it just wasnt up to the job of running it properly, because I had everything on low settings, maybe not.

I know some1 who has an x1950 pro and he has had to get it replaced. I'm reasonably sure this is a pretty buggy series, And yea, sticking the old x1900XT fan on it was not a good plan by ATi. I'll probs move back to nVidia for my DirectX 10 card.

I don't spose it's vista is it? I've heard it can do some wierd things so some games??
wisey12 is offline  
Old 07-04-2007, 02:28 AM   #10 (permalink)
Monster Techie
 
aaronkupen's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 1,848
Send a message via AIM to aaronkupen Send a message via Yahoo to aaronkupen
Default Re: x1950xt issues

Vista could be a possibility, but somehow I think it's unlikely. If i get bored this weekend I might install XP on my rig and try it out.
__________________

__________________
Desktop - Antec Sonata III
Intel Core i3 540
4 GB DDR3-1600 memory
ATI Radeon HD 5670
Windows Vista Business x64
aaronkupen is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hrrm I wonder...if an X1950XT will have enough power Sora New Systems | Building and Buying 9 07-17-2007 10:05 PM
Issues with Laptops theopus Laptops and Notebooks 5 07-06-2007 04:29 PM
Having issues with msnger and internet blazezaku Computer Networking and Internet Hardware 1 06-23-2007 10:14 PM
x1950XT vs 8800 gts 320 veg1992 New Systems | Building and Buying 49 06-09-2007 02:11 AM
Mate's PC has issues AT2005 Hardware Repairs and Troubleshooting 5 05-15-2007 06:29 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.