Windows 7 still can't find the second hard drive... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-05-2015, 01:32 PM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2015
Location: UK
Posts: 16
Default Windows 7 still can't find the second hard drive...

Hi, again:

New computer build:

Gigabyte 970A-DS3P AM3+ DDR3
WD 1TB SATA lll Desktop Hardrive
Seagate Barracuda 250GB SATA ll Desktop Hardrive
AMD FX 4300 PILEDRIVER 3.8GHZ QUAD CORE SOCKET AM3+ CPU
Gigabyte GV-N210SL-1GB GeForce 210 Graphics Card
Crucial CT51264BA160BJ 4GB DDR3 SDRAM 1600MHz x2
Alpine Blue 700W 38 AMP Single Rail PSU


It's been a long week... I finally have a fresh, new, install of Windows 7 on a new GPT formatted hardrive, everything running as sweet as you could wish for. No problems.

Problem: The second 250GB hardrive, previously used as an MBR formatted data backup drive, has so far not been recognised by Windows on this new computer since Day 1... I have today removed it and put it back in the old MBR computer and deleted all the volumes/partitions on it leaving just 'unallocated space' (data loss not a problem, there are other backups)...

I have now put it back into the new computer, BIOS doesn't see it (previously the BIOS used to recognise it OK) and on entering Windows 7 Disk Management that doesn't see it either...

I'm stuck again... Any ideas? Thanks in advance
__________________

fonebone is offline   Reply With Quote
Old 02-05-2015, 01:56 PM   #2 (permalink)
True Techie
 
SubliminalX7's Avatar
 
Join Date: Jan 2015
Location: 10.0.0.NO
Posts: 239
Default Re: Windows 7 still can't find the second hard drive...

But it does recognize it on another machine?
__________________

__________________
Under_Score
------------------------------------------------
CPU: Intel Core i7 2600K @ 3.4 GHz | Cooling: Just Fans | Motherboard: BioStar Tz68K+ | RAM: Cosair Vengeance16GB (4X4GB) DDR3 @ 1600MHz | Graphics: Nvidia Geforce 560 TI | HDD: 1 TB Western Digital (want SSD for OS) | Sound: On-Board sound | PSU: CORSAIR HX Series HX850 850W | Case: Cooler Master CM Storm Scout SGC-2100-KWN3 | OS's: Window 7 Professional x64, Kali Linux 1.0.9 | Display: Dell 24-inch HD, Samsung 24-inch HD
SubliminalX7 is offline   Reply With Quote
Old 02-05-2015, 02:10 PM   #3 (permalink)
Newb Techie
 
Join Date: Feb 2015
Location: UK
Posts: 16
Default Re: Windows 7 still can't find the second hard drive...

Thanks for the reply, X7, but yes... that's how the partitions were deleted back to 'unallocated space'
fonebone is offline   Reply With Quote
Old 02-05-2015, 04:23 PM   #4 (permalink)
True Techie
 
SubliminalX7's Avatar
 
Join Date: Jan 2015
Location: 10.0.0.NO
Posts: 239
Default Re: Windows 7 still can't find the second hard drive...

Quote:
Originally Posted by fonebone View Post
Thanks for the reply, X7, but yes... that's how the partitions were deleted back to 'unallocated space'
right lol do you have another hdd you can try to see if the bios recognizes it?
__________________
Under_Score
------------------------------------------------
CPU: Intel Core i7 2600K @ 3.4 GHz | Cooling: Just Fans | Motherboard: BioStar Tz68K+ | RAM: Cosair Vengeance16GB (4X4GB) DDR3 @ 1600MHz | Graphics: Nvidia Geforce 560 TI | HDD: 1 TB Western Digital (want SSD for OS) | Sound: On-Board sound | PSU: CORSAIR HX Series HX850 850W | Case: Cooler Master CM Storm Scout SGC-2100-KWN3 | OS's: Window 7 Professional x64, Kali Linux 1.0.9 | Display: Dell 24-inch HD, Samsung 24-inch HD
SubliminalX7 is offline   Reply With Quote
Old 02-05-2015, 04:27 PM   #5 (permalink)
Newb Techie
 
Join Date: Feb 2015
Location: UK
Posts: 16
Default Re: Windows 7 still can't find the second hard drive...

..Yes, of course, that's what the fresh, new, install of Windows 7 is on...
fonebone is offline   Reply With Quote
Old 02-05-2015, 04:28 PM   #6 (permalink)
True Techie
 
SubliminalX7's Avatar
 
Join Date: Jan 2015
Location: 10.0.0.NO
Posts: 239
Default Re: Windows 7 still can't find the second hard drive...

Quote:
Originally Posted by fonebone View Post
..Yes, of course, that's what the fresh, new, install of Windows 7 is on...
yeah but it recognizes the win 7 hdd right? i'm saying do you have another secondary hdd you can use to test out?
__________________
Under_Score
------------------------------------------------
CPU: Intel Core i7 2600K @ 3.4 GHz | Cooling: Just Fans | Motherboard: BioStar Tz68K+ | RAM: Cosair Vengeance16GB (4X4GB) DDR3 @ 1600MHz | Graphics: Nvidia Geforce 560 TI | HDD: 1 TB Western Digital (want SSD for OS) | Sound: On-Board sound | PSU: CORSAIR HX Series HX850 850W | Case: Cooler Master CM Storm Scout SGC-2100-KWN3 | OS's: Window 7 Professional x64, Kali Linux 1.0.9 | Display: Dell 24-inch HD, Samsung 24-inch HD
SubliminalX7 is offline   Reply With Quote
Old 02-05-2015, 04:29 PM   #7 (permalink)
True Techie
 
SubliminalX7's Avatar
 
Join Date: Jan 2015
Location: 10.0.0.NO
Posts: 239
Default Re: Windows 7 still can't find the second hard drive...

Also are you using any special bios settings like secure boot, uefi settings?
__________________
Under_Score
------------------------------------------------
CPU: Intel Core i7 2600K @ 3.4 GHz | Cooling: Just Fans | Motherboard: BioStar Tz68K+ | RAM: Cosair Vengeance16GB (4X4GB) DDR3 @ 1600MHz | Graphics: Nvidia Geforce 560 TI | HDD: 1 TB Western Digital (want SSD for OS) | Sound: On-Board sound | PSU: CORSAIR HX Series HX850 850W | Case: Cooler Master CM Storm Scout SGC-2100-KWN3 | OS's: Window 7 Professional x64, Kali Linux 1.0.9 | Display: Dell 24-inch HD, Samsung 24-inch HD
SubliminalX7 is offline   Reply With Quote
Old 02-05-2015, 05:47 PM   #8 (permalink)
Newb Techie
 
Join Date: Feb 2015
Location: UK
Posts: 16
Default Re: Windows 7 still can't find the second hard drive...

Well... nothing to test out. There are two 100% functioning hard drives here. One is formatted with an MBR, the unrecognised drive in question, the other a GPT formatted hard drive running Windows 7 x64...

Relevant BIOS settings, as I see it, on entering Windows x64:

1) All frequencies, temperatures, sizes, etc, etc reported to be OK

2) Nothing overclocked

3) Just about everything set to Auto

4) SATA PORT 1 reports Not Present - This is where the drive in question is. (..Whereas before the MBR partitions were deleted down to the current 'unallocated space' it reported the drive OK, even though Windows didn't see it at all).

5) Boot Mode Selection - UEFI Only

6) Storage Boot Option Control - UEFI Only

7) Other PCI Device ROM Priority - UEFI OpROM

8) OnChip SAT Controller - Enabled

9) OnChip SATA Type - AHCI

10) SATA Hot Plug on PORT 0 through 5 - Disabled

11) SATA Power on PORT 0 through 5 - Enabled

Thanks for your time...
fonebone is offline   Reply With Quote
Old 02-05-2015, 05:53 PM   #9 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Windows 7 still can't find the second hard drive...

Tried disabling UEFI for the MBR disk?

MBR doesn't work under UEFI, IIRC.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 02-05-2015, 06:24 PM   #10 (permalink)
Newb Techie
 
Join Date: Feb 2015
Location: UK
Posts: 16
Default Re: Windows 7 still can't find the second hard drive...

Hi carn...

I changed 5) to UEFI and Legacy
I changed 6) to UEFI First
I left 7) at UEFI OpROM

...No change on booting up to Windows

So...

I changed 5) to Legacy Only
I changed 6) to Legacy Only
I changed 7) to Legacy OpROM

Network Stack has always been Disabled, by the way
..& EHCI Hand-Off has always been on Disabled.

... So, all of a sudden on booting I have to "Choose an Operating System to Start" - Windows 7, the only one there...

... but No change in Windows Disk Management.. Still no sign of the second hard drive (I've even just had the sides off and checked all the cables are pressed home again )
__________________

fonebone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 8 install can't find my hard drive ChuckTesta Microsoft Windows and Software 41 08-28-2013 04:03 PM
Can I still use my hard drive? EnishiSG Hardware Repairs and Troubleshooting 1 03-01-2008 12:49 PM
windows can't find my hard drive plowman123 Microsoft Windows and Software 5 12-28-2004 02:50 PM
can't find my second hd mono11 Monitors, Printers and Peripherals 12 12-22-2003 10:45 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.