Why is my Oblivion gameplay so laggy with this machine? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 03-31-2006, 10:41 AM   #1 (permalink)
Super Techie
Join Date: Dec 2005
Posts: 429
Default Why is my Oblivion gameplay so laggy with this machine?


-AMD Athlon 64 3700+ processor

-1 gig dual channel ram

-256mb 7800gt Vanilla graphics card (JATON ROFL)

-450 watt Antec Power supply

During the introduction of the game with the max video settings and without antialiasing i got down to 15 fps during the fighting scenes. Isn't this really low for my setup? People with supposedly lesser machines are saying they don't drop below 30 fps with 5 enemies on the screen or more. I don't get it. Any ideas?

My card is clocked stock at 400/1.0

stainer711 is offline  
Old 03-31-2006, 10:43 AM   #2 (permalink)
Lord Techie
Nitestick's Avatar
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473


Visit my website - nitestick.net
"Guitar is cool. If you donít think the guitar is cool, then youíre stupid. And I will fight you! " - Brendon Small
I'm sorry but I do not accept support requests via IM, email, or personal messages
You can contact me for Forum related issues via PM only.

Nitestick is offline  
Old 03-31-2006, 10:45 AM   #3 (permalink)
Join Date: Mar 2006
Posts: 60

What settings are you running on? With a 7800GT, you need to run 1024x768 no AA. Turning down the grass view distance will also really help. Grass is like the most demanding thing in this game.
BioT3ch is offline  
Old 03-31-2006, 10:54 AM   #4 (permalink)
Super Techie
Join Date: Dec 2005
Posts: 429

I have the correct drivers. I only have the resolution at the default one.
stainer711 is offline  
Old 03-31-2006, 11:51 AM   #5 (permalink)
Ultra Techie
Join Date: Dec 2005
Posts: 512

Apparently to run Oblivion with everything maxed out your going to need a SLI set up. Even though you've got 7800GT this will not be able to play it on maxed out settings. like BioT3ch said try dropping the resolution down but keep everything else the same. Then if the problem persists then start dropping the settings for the grass etc.

Life is too important to be taken seriously - Oscar Wilde
Metr01973 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:44 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.