Why I still get lag - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-14-2009, 05:55 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2009
Posts: 3
Default Why I still get lag

Hello,

I have what I like to think is a fast gaming computer. The specs are:

2 Nvidia 9800 GX2's (SLI enabled)
Nvidia Nforce 790i Motherboard
4 GB RAM at 1333 MHz
Intel Core 2 Duo E8600, 6MB L2 at 3.33 GHz, 1333 MHz FSB
Lots of HDD space
Razer Baracuda sound card
24" monitor
Vista 32 - bit

Let me know if you need more details. I don't know if I have high standards or what but I expect (at least) 50 - 60 FPS with all settings maxed out. For some reason, I can't get that. I can never run any relativley new game at all max settings with 50 - 60 FPS. I think my hardware is pretty up to date and my drivers are all new. For example, Darkest Of Days will only play smoothly will all the settings LOW for some reason. Lord Of The Rings Online still lags even with some settings toned down like AA and shadows. I use a website that checks if my PC will run certain games and it always shows my PC at the very top of the chart. Can sombody help me?
__________________

Kingopersia is offline  
Old 10-14-2009, 08:19 PM   #2 (permalink)
 
iFargle's Avatar
 
Join Date: Jan 2009
Location: United States
Posts: 4,024
Default Re: Why I still get lag

What's your PSU?
__________________

__________________
7700k • 32GB RAM • 512GB 960 Pro • GTX 1080 • NCase M1
15" Retina MBP || 64GB Nexus 6P || 64GB iPad Air 2
Battle.net: iFargle #1561 || Steam/Origin: iFargle
iFargle is offline  
Old 10-14-2009, 09:14 PM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2009
Posts: 3
Default Re: Why I still get lag

Quote:
Originally Posted by iFargle View Post
What's your PSU?
I think it's 900 watts
Kingopersia is offline  
Old 10-14-2009, 09:19 PM   #4 (permalink)
 
iFargle's Avatar
 
Join Date: Jan 2009
Location: United States
Posts: 4,024
Default Re: Why I still get lag

Check to make sure your 12V rails match the requirements on your video cards. I've heard of similar issues like this happening due to low amperage.
__________________
7700k • 32GB RAM • 512GB 960 Pro • GTX 1080 • NCase M1
15" Retina MBP || 64GB Nexus 6P || 64GB iPad Air 2
Battle.net: iFargle #1561 || Steam/Origin: iFargle
iFargle is offline  
Old 10-14-2009, 09:48 PM   #5 (permalink)
Newb Techie
 
Join Date: Oct 2009
Posts: 3
Default Re: Why I still get lag

Quote:
Originally Posted by iFargle View Post
Check to make sure your 12V rails match the requirements on your video cards. I've heard of similar issues like this happening due to low amperage.
what do you mean "12V rails?" Do you mean the cords pluged from the power supply straight into the video cards? If so, what also do you mean by "match the requirements?"
Kingopersia is offline  
Old 10-14-2009, 10:27 PM   #6 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: Why I still get lag

no check the sticker, it'll say how many Amps on each 12V rail.
__________________

__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lag after ~30 seconds of playing Daner Hardware Repairs and Troubleshooting 1 09-13-2009 03:46 PM
Very strange Lag problem. Drizzt Computer Networking and Internet Hardware 9 07-06-2009 02:06 PM
Warcraft 3/ Starcraft Lag! Da Viksta PC Gaming 0 05-16-2009 02:23 PM
converting .avi files but getting audio lag stb1swat Computer Audio and Multimedia 5 12-24-2008 04:31 PM
Tv tuner lag Ind3siszive Hardware Repairs and Troubleshooting 5 06-04-2008 11:49 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.