Weird problem with speakers not receiving electricity - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Thread Tools Display Modes
Old 08-29-2016, 02:38 AM   #1 (permalink)
Newb Techie
Join Date: Aug 2016
Location: Greece
Posts: 1
Default Weird problem with speakers not receiving electricity


What happened is really weird.
Yesterday i removed the speakers(z506) from electricity in order to do some cable management (they worked just fine before i started). While i was doing the job i had the logitech z333 set from the other computer in the room playing music to keep me company. After i was done with the cables i plugged everything back in and shut the 2nd computer down. After successfully booting into the 1st computer i tried to put some music on and the speakers wouldn't power on. The orange indicator wouldn't go on and the speakers wouldn't do anything.. I checked connections and stuff several times, even plugged them in a different socket in my house but still nothing. What makes this weird is that the same phenomena appeared on the speakers of the 2nd computer, on which i hadn't performed any changes or cable management or even removed its power! Could you tell me what might have happened and how to solve this problem? Are my speakers useless now?

galvador is offline   Reply With Quote
Old 08-29-2016, 07:38 AM   #2 (permalink)
Night Ninja
MidnightShadow's Avatar
Join Date: Jun 2015
Location: USA
Posts: 680
Default Re: Weird problem with speakers not receiving electricity

Try plugging them into a different outlet somewhere else and see if they work. Also check your breaker box and make sure you haven't tripped a breaker/blown a fuse, although nothing at that outlet should work if that's the case.
MidnightShadow is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
PC not enough electricity or power?? mickeyO Hardware Repairs and Troubleshooting 3 01-19-2008 02:50 PM
Receiving Email Notification but it's not there? Burnselk Forum Admin, Announcements & Feedback 4 02-11-2007 01:52 PM
Not receiving messages and invites from some contacts Central Viruses, Spyware and Malware 3 10-02-2006 11:49 AM
Bytes sent but not receiving. flipflop Computer Networking and Internet Hardware 3 09-02-2006 01:19 PM
not receiving all of reply emails Ankush09 Off Topic Discussion 2 02-13-2005 05:17 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.