WD Elements External HDD 750gb - Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-14-2009, 03:59 PM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 3
Default WD Elements External HDD 750gb - Problem

Im running XP SP3. I have a ton of data on this 750gb external hd:

WD ELEMENTS 750 GB external hard drive NEW IN RETAIL BX - eBay (item 220350129875 end time Feb-22-09 21:45:31 PST)

Its hard to find any info on this model. I was converting a mkv file to a mp4 using XenonMKV on the external and about 10 minutes into it the blue light was flashing on the externals case and it sounded like a clicking noice (how it does when a CD players laser gets stuck). The only way to get it to stop it was to shut down the computer.

When i started it back up, the hd wasn't recognized or being mounted as a drive anymore so its not showing up in "My Computer". When I look for the drive in device manager, it only shows up as "WD". Ive tried to uninstall the driver and reinstall it but that didnt work. Ive also tried other USB inputs and other computers, and the 360 and nothing will recognize it.

When I listen to the external when i plug it in, (there is no on/off switch, just usb and power plug) I hear it starting to spin, attempting that 3 times, then stopping all together.

Ive used a program called testdisk-6.10.win to try to repair the partition table because in my researching, Ive found that others have had this problem and that fixed it. That program says that if it recognizes it but it recognizes the wrong size, then the repair wont work effectively. Well thats exactly what happened. It recognized it as a 2TB hdd when its only 750gb.

I have about 600gb of data on the hdd (including mine and the wifes turbotax pdf's) and im not going to spend 1000's for dollars for a recovery because i think there might be a fix or solution to my problem.

Does anyone have any suggestions?!
__________________

poolman is offline  
Old 02-14-2009, 04:14 PM   #2 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: WD Elements External HDD 750gb - Problem

Clicking sounds are not good? Have you tried putting it in the freezer for a few hours? Keeping in mind if it works you will only get a few hours out of it so just use the time to back up data.
__________________

__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 02-14-2009, 04:20 PM   #3 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 3
Default Re: WD Elements External HDD 750gb - Problem

No I havent done the freezer trick yet.

Its not clicking anymore though, just that one time. Now, when I start it up, it tries to spin 3 times and feels like it "doesnt catch".

Ive also heard of opening the external casing and just hooking up the hdd inside to my machine. The problem with that is i hear it might be a SATA hdd which i dont have on my machine. Hopefully its IDE but i dont want it to come to that. Does anyone know whats inside these 750gb WD Elements externals?

Also, the external is less than 3 months old. So i dont think its an issue of wear at all. Help please!
poolman is offline  
Old 02-14-2009, 04:28 PM   #4 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: WD Elements External HDD 750gb - Problem

WD site does not give the drive specs but I would assume based upon size that it is sata. Have you tried connecting it to another computer?
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 02-14-2009, 04:33 PM   #5 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 3
Default Re: WD Elements External HDD 750gb - Problem

through the usb yes. ive also plugged it into the xbox 360's usb that normally recognizes it and nothing does. i know it wants to work because i can see it in device manager but now its changed names. Before it used to say something like "WD Elements External" and now it just says "WD" so my computer definetly sees it.
poolman is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDD problem.. SiZcO Hardware Repairs and Troubleshooting 12 02-08-2009 10:31 PM
External hdd backup alternatives??? ingeborgdot Computer Networking and Internet Hardware 6 01-25-2009 11:02 PM
50 gig transfer time = 11 hours. External HDD. Jayce Hardware Repairs and Troubleshooting 7 09-06-2008 11:53 AM
Windows won't install external hdd drivers Pinscher Hardware Repairs and Troubleshooting 2 08-26-2008 09:29 PM
Quick HDD question: Which 750gb drive? bengance New Systems | Building and Buying 6 05-12-2008 08:07 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.