Video card STILL not working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-03-2013, 02:55 AM   #1 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Video card STILL not working

I have a gtx660, and it stopped working out of the blue one day a few months ago. I replaced it, assuming it was the card, but the new one didn't work either. I just replaced the motherboard, thinking if its not the video card, it must be the PCI-E port. And still, nothing. The card worked fine for a few months, then suddenly stopped. The only thing I can think of that might have had an effect was that I unknowingly had my computer hooked up to a non-grounded outlet for a few weeks, and that might have screwed with the PSU. I was, however, using the card fine for about another month after I switched to a grounded outlet, before it suddenly stopped. Unless PSU damage can be gradual and take effect weeks after the cause is gone, I don't think that is plausible either. I don't have another rig to test hardware on, so I have the inconvenience of having to send back a part which I only suspect might be causing the problem, definitely not ideal :/ I'm running an 880gm-le fx mainboard, a gtx660, and a corsair cx500 if that's of any help to you guys, thank you! ----EDIT---- Maybe I should mention what "stopped working" actually means *facepalm* As I said the card was working fine, then one day it wasn't recognized at all. While the fan in the card is spinning fine, the BIOS doesn't see it and neither does GeForce Experience. When I plug the DVI from the monitor into the card the monitor's message saying "no source found" goes away, but then it just goes to black screen. So to actually use the computer I need to plug into the mainboard.
__________________

Jayteescout is offline   Reply With Quote
Old 10-03-2013, 02:56 AM   #2 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Re: Video card STILL not working

Sorry its a little hard to read, I did have it formatted.
__________________

Jayteescout is offline   Reply With Quote
Old 10-03-2013, 06:39 AM   #3 (permalink)
Wizard Techie
 
Join Date: May 2011
Posts: 3,077
Default Re: Video card STILL not working

What do you mean by stopped working....You had no screen at all? or were you getting errors? What driver are you currently using on the gtx 660?
Joe C is offline   Reply With Quote
Old 10-03-2013, 07:23 PM   #4 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Re: Video card STILL not working

Edit^^
Jayteescout is offline   Reply With Quote
Old 11-03-2013, 09:42 PM   #5 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Re: Video card STILL not working

Well, after getting an RMA on both the GPU and the mainboard with no success, I turned to my last resort: a Staples EasyTech $70 diagnosis... The problem was that the GPU wasn't pushed in all the way... WTF MAN! But really it's no ones fault but my own. This is my first ever self build and I was just being too gentle I guess; I didn't want to hurt my baby. At the end of the day (3 months) I'm just happy it works.

Now for some long awaited gaming!
Jayteescout is offline   Reply With Quote
Old 11-03-2013, 10:36 PM   #6 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,279
Default Re: Video card STILL not working

Haha wow that has to really suck. Least it's figured out though.
__________________

__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.