Video card problems - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-04-2006, 01:33 AM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2006
Posts: 3
Default Video card problems

I just got an X800 Pro and have been having some problems. First of all, when i boot my pc up, (i have windows xp) on the windows loading screen, there's a bunch of weird blue scratchy dots on the screen. Also, when i try to play a movie, it plays fine except that there is a hasy static over the movie screen of blue, red and other colors. Then when i played FarCry, it would get all glitchy and show huge pixle boxs all over the place. The other weird thing is that there is a bunch of little black dots under my cursor and it gets annoying. It plays fine for battle for middle earth 2 and NFSMW so i donno. Anyways, PLEASE respond, i need some possibilities or answers,

Thanks
__________________

aaasnwbordr123 is offline  
Old 03-04-2006, 01:36 AM   #2 (permalink)
Lord Techie
 
Nitestick's Avatar
 
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473
Default

have you changed from nVIDIA to ATI? have you installed the latest drivers?
__________________

Nitestick is offline  
Old 03-04-2006, 01:37 AM   #3 (permalink)
Monster Techie
 
Join Date: Sep 2005
Location: N/A
Posts: 1,486
Default

What drivers are you using? What video card did you have before you got the X800? If it was an Nvidia card, you need to clear out all of the old drivers.
Vybuni is offline  
Old 03-04-2006, 09:36 PM   #4 (permalink)
Newb Techie
 
Join Date: Mar 2006
Posts: 3
Default

my old card was a radeon 9600 PRo and it came with a driver cd, would that have the latest drivers?
aaasnwbordr123 is offline  
Old 03-04-2006, 10:31 PM   #5 (permalink)
Monster Techie
 
Join Date: Sep 2005
Location: N/A
Posts: 1,486
Default

Not necessarily. Go to ATI's site to see what the latest drivers are.
Vybuni is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.