Video card problem? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-23-2006, 06:15 AM   #1 (permalink)
Ultra Techie
Join Date: Dec 2004
Location: New Brunswick, Canada
Posts: 511
Send a message via MSN to LegendBreath
Default Video card problem?

I was playing Oblivion, and then there was a loading because I was going in another area. And then, a blank screen (after the loading) but there was still music. It was like that for around 2 mins. After, I had a BSOD and the only thing I could of read was "nv4_disp". Is that a problem with my video card? It's only been a week that I have it. It's a NVIDIA GeForce 7600 GT CO (PCI-E). I don't think it ever did that with my old video card (ATI x600). Sometimes, the game only hangs, like a BIG lag, for around 2 mins but it doesn't crash up my PC.

So, does anyone knows my problem?

LegendBreath is offline  
Old 04-23-2006, 06:29 AM   #2 (permalink)
Lord Techie
Nitestick's Avatar
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473

have you completely removed the catalyst drivers with driver cleaner? if it reports a file like that with the BSOD it is a driver issue. but your are right it is related to your graphics card but it is a driver problem not a hardware problem. i suggest you use driver cleaner to remove all current video drivers and then re-install the nVIDIA Forceware driver version 81.98 or later.

Visit my website -
"Guitar is cool. If you donít think the guitar is cool, then youíre stupid. And I will fight you! " - Brendon Small
I'm sorry but I do not accept support requests via IM, email, or personal messages
You can contact me for Forum related issues via PM only.

Nitestick is offline  
Old 04-23-2006, 07:10 AM   #3 (permalink)
Ultra Techie
Join Date: Dec 2005
Posts: 512

Use driver cleaner, remove the driver using the control panel first and then run driver cleaner. I use it just to update my Nvidia drivers, I uninstall the old one and then use driver cleaner and then install the new one. I was getting problems like yours when I wasn't taking the old version driver off before installing the new one. Here's the link to driver cleaner. Hope it helps.

Life is too important to be taken seriously - Oscar Wilde
Metr01973 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.