Video Card Issues? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 05-11-2009, 11:22 PM   #1 (permalink)
Newb Techie
Join Date: May 2009
Location: South Carolina
Posts: 3
Send a message via AIM to ClassicRed
Default Video Card Issues?

Please bare with my n00bness questions~(And here's hoping I posted in correct spot D: >.< Not entirely sure this is hardware)

I recently turned up all my graphics with my ATI Control Center(SAPPHIRE 100245L Radeon HD 4850 512MB) (All the ones under 3D) and my game(Final Fantasy XI) looks, to me amazing~

At that time I noticed whenever I did a 'roll over' type option in FireFox (like scrolling down the history list) my game/pc would get very laggy(Game would go down to 1-2FPS normal being 29-29.5FPS) if I minimized the game everything would run fine -- So for the most part it didnt bother me.......That said I recently started playing with Windows Sidebar and I can not have the side bar up and the game up at the same time it causes that 1FPS lag...~ The obvious answer I guess is to turn my graphics options back down But I was hoping for another alternative if at all possible~

On another note I would like my stupid card name to be in my 'display' settings for deskop resolution and not the silly 4800 series crap D:! I figured out I needed to goto the card manufacturer but I found 3 options that could be my card XD but beats the heck outa me which is which as they all look the same to me! (entering model number didnt help either )

Sapphire Technology - graphics

PC Specs if needed~
Game Resolution(I play it in a window'd mode): 1152x864
Desktop Resolution: 1920x1080
# Operating system:Windows XP Ultimate (SP 3)
# CPU type: AMD Athlon(tm) 64 X2 Dual Core Processor 6400
# CPU Speed (GHz):3.2
# Memory (GB):3.249 (Should read 4gigs one day i'll upgrade to 64bit day)
# Card: ATI Radeon HD 4850
# Mobo: ASUS M3A78-T AM2+/AM2 AMD 790GX HDMI ATX AMD Motherboard
# Graphics Driver Version: 8.511.0.0
# Sound: Creative Sound Blaster Audigy SE 7.1

All parts are no more than a month old of usage (Took me a year to build this new pc :3)~ gentle ~.~

ClassicRed is offline  
Old 05-12-2009, 10:47 PM   #2 (permalink)
Call me Mak or K
Mod Emeritus
KSoD's Avatar
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Video Card Issues?

Do you have the latest set of drivers?
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad video card? 35g700 Hardware Repairs and Troubleshooting 3 01-20-2009 11:36 AM
How to rip DVD and convert video with only one converter calmtran Computer Audio and Multimedia 0 11-05-2008 02:36 AM
Video Upconverting software EricB Computer Audio and Multimedia 5 09-25-2008 10:40 PM
damaged video card sb14blue Hardware Repairs and Troubleshooting 2 05-13-2007 02:13 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.