Video Card Drivers - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-10-2005, 11:37 PM   #1 (permalink)
Indeed.
 
Greg's Avatar
 
Join Date: Dec 2004
Posts: 1,600
Default Video Card Drivers

Kind of a noobish question, but I have never come across this before so oh well: Would installing potentially wrong video card drivers be a problem? I am not sure of the model of the card on a computer, and I want to update the drivers.
__________________

__________________

Greg is offline  
Old 09-11-2005, 10:30 AM   #2 (permalink)
Lord Techie
 
PZEROFGH's Avatar
 
Join Date: Jul 2005
Posts: 7,553
Send a message via AIM to PZEROFGH
Default

download everest and see what video card you have, or right click my computer, properties, hardware, device manager, display driver, and you can see what video card you have, if its ati go to www.ati.com, if its nvidia go to...www.nvidia.com
__________________

__________________
Hmmm?
AIM/Xfire - pzerofgh
PZEROFGH is offline  
Old 09-11-2005, 10:47 PM   #3 (permalink)
Indeed.
 
Greg's Avatar
 
Join Date: Dec 2004
Posts: 1,600
Default

Yeah, I did the latter and it came up with ATI, but it doesn't have the specific model. Does it matter as long as the driver is ATI also?
__________________

Greg is offline  
Old 09-12-2005, 07:25 AM   #4 (permalink)
Banned
 
Join Date: Jul 2005
Posts: 76
Default

Hmm... Try to check in computer manager>device, what Video card you have.
Also try to check your current driver, for what exactly device it supports.
Why you should update your driver?

Another way uninstall current driver and loock which device need driver. Than you can try to find driver in the Windows updates.
Defence is offline  
Old 09-12-2005, 07:54 AM   #5 (permalink)
Ultra Techie
 
Join Date: Aug 2004
Posts: 976
Default

The Catalyst and Forceware drivers are unified. That is, they'll work with any ATI or nVidia card respectively.
__________________
AMD X2 4400+ Toledo 1MB/Asus A8N-SLI Deluxe/2GB Kingston HyperX/SLI Gigabyte 7800 GTX 256MB/Creative SB Audigy 2 ZS Plat w/ Creative Inspire 6.1 speakers /180GB Hitachi PATA/19\" AG Neovo F-419 LCD/OCZ PowerStream 600W PSU/WinXP Home SP2
DoomUK is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.