Very Laggy PC! - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-20-2010, 11:11 AM   #11 (permalink)
Newb Techie
Join Date: Apr 2010
Location: Don't Mess with Texas. Texas admins that is
Posts: 8
Default Re: Very Laggy PC!

You need to tell us what video card you have so we know if your memory is registering correctly.

That is to say that if you have a 64bit OS and a Graphics card of XXXMB memory, Windows must address that much in reserved space. This can make 4GB appear less than it is. However - I run a 768MB 8800GTX on a 32-bit Vista OS (don't ask) and my OS still shows 4.00GB RAM. Obviously this is incorrect. Windows 7 has fixed this issue (as well as Vista SP2 which I don't have - again don't ask) to my knowledge.

That said, run memtest ASAP, swap RAM, test it out.

And yes to concur with an earlier poster - heat absolutely can slow down a system as Intel chips for years have had speedstepping technology to protect the chips(as well as save power consumption).

BradMcKinley is offline  
Old 04-20-2010, 11:12 AM   #12 (permalink)
Super Techie
LFCJohnSmith's Avatar
Join Date: Dec 2008
Location: Liverpool UK
Posts: 413
Default Re: Very Laggy PC!

Originally Posted by MindoverMaster View Post
You never said what OS you have. There must be a problem with your memory. As patonb suggested, run memtest.
I did say though that I had a x64 bit OS. I have already run mem test and it was fine, like I said I think I just need a bit more CPU power cause when I start multi tasking then thats when the problems start and the cpu usage gets higher.


LFCJohnSmith is offline  
Old 04-20-2010, 05:49 PM   #13 (permalink)
Techie Beyond Description
MindoverMaster's Avatar
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Very Laggy PC!

We were asking which OS you had, not that it was x64 or x32, you said that prior.
__________________ Steam Account
MindoverMaster is offline  
Old 04-20-2010, 06:50 PM   #14 (permalink)
Resident Nightowl
Fat.Clown's Avatar
Join Date: Dec 2006
Location: Twin Cities
Posts: 3,315
Default Re: Very Laggy PC!

do you defrag your hard drive regularly?

the laptop I tried recently... (underclocked dual core @ 1.3 Ghz) can browse the web just fine

Fat.Clown is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Youtube HD, what reasons would it run laggy on a pc? jonny_uk Off Topic Discussion 9 03-22-2010 06:38 AM
Laggy Gameplay durabox PC Gaming 5 11-03-2009 08:05 PM
Rock Band for the Wii, laggy? Seria Nintendo 8 11-02-2009 06:45 PM
pc: need for speed undercover sometimes laggy robina_80 PC Gaming 3 12-04-2008 04:00 PM
laggy crysis performance jpfan18 PC Gaming 10 11-16-2007 09:11 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:41 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.