USB2.0 Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-09-2006, 05:33 AM   #1 (permalink)
Newb Techie
 
Join Date: Nov 2006
Posts: 1
Default USB2.0 Problem

Hi
I need a some one to help me
I am using Windows XP Media Centre 2005 SP2.

I have problem with my USB 2.0. Every Time i try to plug in any usb device it says the device is unrecognized. I tryed all my other 8USBs but no luck. I tryed formating my PC but still no luck. Still stays. I kno it aint the problem with my Windows Media centre 2005 I have been using it for around 2 years now. So i kno its nothing to do with my XP. I tryed uninstalling it from my system, I tryed updating my Drivers for my USB. I also searched online for help. I found quiet few forums but when i followed their instructions STILL NO LUCK. So i was wondering if anyone else had same problems as me and fixed it. I would like someone to help me.

Thx in advance
LCzapla01 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.