USB ports....? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Thread Tools Display Modes
Old 05-02-2013, 04:17 AM   #1 (permalink)
Monster Techie
TheHumanComputer's Avatar
Join Date: Feb 2009
Location: Inside A P c
Posts: 1,181
Default USB ports....?

So.. my PC is all of a sudden... causing me problems... When i plugged my iPhone into it... it ruined my iPhone... i can not charge it, or yeah.. pc will not pick up the phone at all... so i am having to get it replaced... for a 3rd time...

I just plugged an mp3 player into it... and noticed that didn't work either.... went to un-plug it.. and the usb cable was HOT!. and it was only plugged in for about 20 seconds... if that.... Can anyone help me... What is wrong with my PC?

AMD FX 9370 @ 4.4Ghz
Asus Crosshair V Formula Z
Deepcool Genome Case with Watercooling
16GB DDR3 1600Mhz
Areocool 750W Semi Modular PSU
TheHumanComputer is offline   Reply With Quote
Old 05-02-2013, 08:32 AM   #2 (permalink)
There and Back again
Nukem's Avatar
Join Date: Jan 2005
Location: Virginia Beach
Posts: 4,334
Default Re: USB ports....?

Your USB port(s) are shorted out. Something that you plugged into it(them) at one time did it. That I know of, there is no update that will fix that issue... I would get a PCI usb card and try that until I could get a new board. (If even that works)

This is also assuming that you have tried the front USB ports, as well as the back, and all of them don't work. Either way I would get a new board.


Dell 4K S2817Q / Logitech Z-680 / Func MS3 Mouse / Corsair K70
NZXT Source 530 / i7-3770K / Corsair H100 / ASRock Z77 Extreme4 / SoundBlaster Recon3d
Samsung 850 PRO 512GB SSD/Seagate 1TB/2TB/WD 2TB
4x4GB Corsair Vengeance 2133 / PNY GTX 980 ti/ Seasonic M12II 850W
Nukem is offline   Reply With Quote
Old 05-02-2013, 10:50 AM   #3 (permalink)
Super Techie
Veraster's Avatar
Join Date: Jul 2012
Location: Houston TX
Posts: 304
Default Re: USB ports....?

I had a problem where one of my USB ports got shorted out or something. When I plugged anything into it, I'd get an error message saying something like "A USB port has quit working with an error code of 4". Luckily, it was only one port and not the four that were sharing the same motherboard connector.
Buying a PCI usb card would be an easy temporary fix.
If all the usb ports are messed up, that's bad. I would get a new board.
You might want to buy one of those plastic anti-static floor mats to help prevent that from happening again.
my pc specs:
Asus P9X79 Socket 2011
Intel Core i7-3930k @ 4.5GHz OC
Cooler Master 212 Evo
8GB ram
EVGA GeForce GTX 680 4GB
240GB Corsair Force GT SSD
1TB Seagate Barracuda 7200rpm
Cooler Master Silent ProM 850W
Veraster is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:46 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.