Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   Hardware Repairs and Troubleshooting (http://www.techist.com/forums/f77/)
-   -   USB pci card wont work with windows 98 but should! Please help! (http://www.techist.com/forums/f77/usb-pci-card-wont-work-windows-98-but-should-please-help-98276/)

tritty 04-24-2006 07:56 AM

USB pci card wont work with windows 98 but should! Please help!
 
Hi all,

I bought a 4 port USB card (pci) for my old computer running windows 98. It said it supported and 98 and 98 SE, i think ive got SE, so it should have been all good. So I put it in and loaded the drivers and everything, but it wouldnt work. When I went into System, it shows the drivers have loaded, because it calls the device by the name of the driver, but it says the device is not functioning properly because Bios has not given it the required IRQ (interupt request). You must enable the device in Bios. But when I looked in Bios i couldnt find anything relating to being able to enable any sort of USB or PCI device. ANyone got any ideas?

Cheers

jeremy 04-24-2006 09:10 AM

whats your mobo?

FlashDude 04-24-2006 09:32 AM

Go into your bios and turn usb on!! you may need to reinstall the drivers when you are done. If that doesn't work *Get W2K or XP. Also check to see if there are any bios updates for your board.

*Edit -- Oh I almost forgot,,, Make sure you have the proper chipset drivers installed. and any updates for them as well.

tritty 04-24-2006 11:26 PM

Im not sure what the motherboard is cause its really oldschool and I didnt buy it or put it together. I tried looking in system and my computer properties but I couldnt find out what it was. Is there any where it tells you what it is in windows?

About the turning it on in Bios, thats my problem! I cant find option to allow me to turn it on! Do you know in which Bios heading it would be under? If I could find out the name of motherboard, would the manufacturers website still allow me to download updated drivers for it? Its about 8 years old.

Thanks again dudes

jeremy 04-25-2006 12:17 PM

get cpu-z click here , get into the "mainboard" tab and take a screenshot

you got it the wrong way , in bios you should define the pci slots IRQ settings

tritty 04-26-2006 05:56 AM

1 Attachment(s)
Hey, heres the screen shot.
Could you tell me in more detail where the setting for Pci IRQ changes is, how to get to it, and what im changing it to and from?

Cheers again all

jeremy 04-26-2006 10:16 AM

from some reason cpu-z doesnt identify the mobo , get everest click here get into motherboard-->motherboard and take a screenshot

FlashDude 04-26-2006 09:03 PM

http://www.intel.com/support/chipsets/sb/CS-009262.htm

And If you havn't yet download the intel chipset indentifing utility.

Nitestick 04-27-2006 01:34 AM

if i'm not mistaken that is a PII generation chipset (think i used to have a board with that chipset). anyway with a pci card turning on USB in BIOS wouldn't make a difference as that is for onboard usb. i would think that a computer of that generation was ATX and had onboard USB but i may be mistaken. sounds like a classic old IRQ conflict. you might have to do some reading on how to fix this yourself as its kind of hard to explain

tritty 04-28-2006 02:04 AM

hey guys thanks again for the help.
Ok i tried the chipset identifying program, but couldnt get it to to work. I downloaded the version for 98, then 98 se then the one that said all OS, but they all said error, cannot identify system components, or something along those lines.
But the everest program that worked well.
Ive just uploaded the files so i didnt have to bother cutting them down to a size that I could post on here. Haha it took me ages for that other pic. I took screen shots of the motherboard, chipset, bios, cpu, and the usb thing.

http://members.iinet.net.au/~bridge/motherboard.JPG

http://members.iinet.net.au/~bridge/chipset.JPG

http://members.iinet.net.au/~bridge/bios.JPG

http://members.iinet.net.au/~bridge/cpu.JPG

http://members.iinet.net.au/~bridge/usb.JPG

Let me know if they dont work, but I think they should. As for it having onboard USB, it definately doesnt, thats why I'm trying to pu this in.

When I first put the card in, it tried to load drivers already in the windows folder, a file named usb.inf I think. But when it tried to install that it said please insert windows 98 disc, and I did that but it still wouldnt work. So then I fiddled around with the drivers I got with the card, got them installed, but then got the error in System when I tried to look if it was functioning properly... anyway thanks again for all the help guys, I appreciate it


All times are GMT -5. The time now is 06:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.