USB Mass Storage Device - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-13-2005, 07:48 AM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 6
Default USB Mass Storage Device

Hey....
I purchased a USB external hard disk...which actually had a separate case and a Toshiba harddisk...
now my problem is when i plug it into my desktop computer it recognises as an unrecognised device...and when i check the properties it say drivers notinstalled....im using a P4 3.3 with an ASRock motherboard. But when i pulg it into my laptop it recognises an a normal harddisk.....Please help...the main reason i bought it was because i needed to backup my laptop....

Thanks..
__________________

Evolution is offline  
Old 10-13-2005, 07:52 AM   #2 (permalink)
Master Techie
 
Join Date: Feb 2004
Posts: 2,172
Send a message via AIM to Win2kpatcher
Default

What OS is your desktop running? This is the one with the issue right?
__________________

Win2kpatcher is offline  
Old 10-13-2005, 08:04 AM   #3 (permalink)
Ultra Techie
 
Join Date: Jan 2004
Posts: 769
Default

Did the drive come with drivers?

and is ur computer running USB 2.0? (%90 sure it would be.)
__________________
Sprooty is offline  
Old 10-13-2005, 09:46 AM   #4 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 6
Default

well im using Win XP Pro and it did come with drivers but the drivers come only for WIN 98, Win ME and Older.....when i check the properties of the device (know as unknown device in the device manage) it says device drivers not installed....
Evolution is offline  
Old 10-13-2005, 10:02 AM   #5 (permalink)
Lord Techie
 
Nitestick's Avatar
 
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473
Default

connect to the internet. go to the device driver properties and click update driver. allow the computer to search for the driver automatically. it should try connecting to windows update after a while and searching for a driver there. perhaps download something like the driver-guide toolkit from driver-guide.com and see if that can help. search for drivers for the hdd on the net including the words "windows xp"
Nitestick is offline  
Old 10-13-2005, 10:19 AM   #6 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 6
Default

Well i did the update and now it says it cannot find a better match for the driver....and the properties have changed when i removed and put it bak...now it says "This device cannot start. (Code 10)".....
Evolution is offline  
Old 10-13-2005, 10:51 AM   #7 (permalink)
Lord Techie
 
Nitestick's Avatar
 
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473
Default

so did you search for the driver using the model number?
Nitestick is offline  
Old 10-13-2005, 12:06 PM   #8 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 6
Default

Well the driversguide.com tool kit doesn't dectect it at all...now wat...??
__________________

Evolution is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.