USB device not recognized - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-19-2009, 05:47 PM   #11 (permalink)
There and Back again
 
Nukem's Avatar
 
Join Date: Jan 2005
Location: Chattanooga, TN
Posts: 4,402
Default Re: USB device not recognized

here is a link to the mobo you have pictured. Assuming it's the same one and you have XP; under drivers, the second up "USB" 12/29/2003" and you might want to look at updating your bios as well... but I don't see a chipset driver listed, so check your manual for a website that you can go to find drivers. this may not be the right one.

ASRock Motherboard - Product - GE PRO-M2 - Download
__________________

__________________



Dell 4K S2817Q / Logitech Z-680 / Func MS3 Mouse / Corsair K70 LUX rgb
NZXT Source 530 / i5-7600K / Corsair H100i v2 / ASRock Z270 Extreme4
SM951 M2 256GB / 850 evo 1TB / Seagate 2TB / WD 2TB
2x16GB Vengeance LPX DDR4 3000 / evga Classified GTX 980 ti / Seasonic M12II 850W

Nukem is offline  
Old 02-19-2009, 05:55 PM   #12 (permalink)
Junior Techie
 
Join Date: May 2008
Posts: 83
Default Re: USB device not recognized

Thanks Nukem, I looked at the link I see the second one from the bottom, but it says those are for OS win 98 and Me. Is that for me?? I have XP..
__________________

hesson81 is offline  
Old 02-19-2009, 06:04 PM   #13 (permalink)
There and Back again
 
Nukem's Avatar
 
Join Date: Jan 2005
Location: Chattanooga, TN
Posts: 4,402
Default Re: USB device not recognized

your right..I looked at the wrong one... while typing. Sorry...

consult your mobo manual for the website. but I would suggest updating the bios first, then go from there.looks like the latest is 2.80
__________________



Dell 4K S2817Q / Logitech Z-680 / Func MS3 Mouse / Corsair K70 LUX rgb
NZXT Source 530 / i5-7600K / Corsair H100i v2 / ASRock Z270 Extreme4
SM951 M2 256GB / 850 evo 1TB / Seagate 2TB / WD 2TB
2x16GB Vengeance LPX DDR4 3000 / evga Classified GTX 980 ti / Seasonic M12II 850W

Nukem is offline  
Old 02-19-2009, 10:54 PM   #14 (permalink)
True Techie
 
Join Date: Oct 2007
Location: Vancouver, BC
Posts: 184
Send a message via MSN to TheGlazer
Default Re: USB device not recognized

I had the exact same problem before........ all it took was a BIOS update; and everything ran fine afterwards..........
__________________
CM Haf 932
Intel i7860
Asus Maximus 3 Forumula
2x2GB Corsair Dominator GT
XFX 6870 Dual Fan
Intel 80GB SSD
1GB Seagate 7200.12
1GB WD Black
Thermalright Venomous X
Corsair 750W Modular P/S
Samsung T220
Scythe Kaze Master Ace Fan Controller
Genius SW-5.1 1505 Speaker System
Windows 7 Professional 32bit.
TheGlazer is offline  
Old 02-20-2009, 02:14 AM   #15 (permalink)
Imperial Space Womble
 
Harper's Avatar
 
Join Date: Jan 2004
Location: Australia
Posts: 6,903
Default Re: USB device not recognized

Quote:
Originally Posted by hesson81 View Post
I have an external hard drive, doesn't need drivers for the OS that I have (XP). Works great. The problem is I have to use the USB ports on the back of the computer, so I have to get on allo fours, and make it happen. There are two USB ports on the front of the computer that i would love to utilize. When I plug the Drive in, it's powered normally. The light comes on and everything. Then i get the pop up window saying it's unrecognized or may be working improperly. Again, the USB ports in the back of the computer work fine with the drive.

I google it and ran into different senerio's, like dust, or totally disconnect power to the computer (unplug power supply). None of it works. Does anyone know what the problem is???

Thanks
My experence has found that the front panel USB normally does not have enough power to power up external hard drive. However this does every from case / motherboard and hard drive manufacturer. Plus it also depend on the quality of the USB cable. Like I got my little 15cm USB cable with I guard with my life as it's allows me to connect my hard drive to the front panel where i have seem others fail.

I have seen some double USB adpators for external hard drives. There is 2 USB-AM connections where the 2nd one is there to drawn more power from the PC.
__________________

"I FEEL SO GOOD I FEEL SO NUMB, YEAH!!!" -- Rob Zombie
Main Rig - AMD FX-8350x8 4.0Ghz CPU, 4x 8Gb (32Gb) DDR3 Ram, Gigabyte GA-970A-D3, GeForce GT 970 4Gb, 1x 256Gb SSD\8Tb (3+2+2+1) SATA HDD, DVDRW, SB X-Fi, Win 10 (64-bit)
Asus N61JV-JX231V - Intel Core i5 3437u (1.9 - 2.4 GHz), 12GB, 640GB, 16" Display, nVidia 325M 1Gb, DVD-RW, Win 10 (64-bit)
Mobile Phone : Samsung Galaxy 5 Note SM-N920IConsole : Play Station 4
Harper is offline  
Old 02-20-2009, 02:47 AM   #16 (permalink)
Junior Techie
 
Join Date: May 2008
Posts: 83
Default Re: USB device not recognized

Alright, I'm updated to 2.8 (bios) now, nothing working. As suspected. I took it all apart and looked at the USB interface, nothing blocking it. Could be a bad interface. I'll look at the connection on the mother board, haven't done that yet...

Does anyone know How I can look up which chip set I am on, on the computer???

Thanks
__________________

hesson81 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
All VOIP programs (skype, yahoo, msn) cause PC crash (only voice calls, chat ok)??? disksko Hardware Repairs and Troubleshooting 10 03-17-2009 09:17 AM
Installing Ubuntu. 95BlackGA Linux and Open Source 1 10-16-2008 09:44 PM
I get low FPS in WoW with Geforce 9600GT Superclocked! EliteScouter Hardware Repairs and Troubleshooting 4 10-03-2008 09:38 AM
I can not mount my USB device! lyecdevf Linux and Open Source 4 09-27-2008 11:04 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.