USB 2.0 not recognized as high speed ports - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 11-28-2011, 08:22 AM   #1 (permalink)
Newb Techie
Join Date: Nov 2011
Posts: 2
Question USB 2.0 not recognized as high speed ports

Recently my USB ports are not performing as high speed ports like they're supposed to. They're all 2.0 ports, but when I plug something in to any of the ports, I get a message saying "This USB device can perform faster if you connect it to a High-Speed USB 2.0 port" then says "click here for a list of available ports".

When I click for the available ports, all 6 of my USB ports are listed, but they all do the same thing.

I'm running Windows Vista SP2, just ran update to make sure everything is up to date, opened device manager to make sure there werent any conflicts with my ports, and scanned and updated drivers for all of the ports. Still, I get the same message and the same slow performance.

Any idea what could be causing this?

And just to be clear, they're showing up in device manager as "Enhanced Host Controllers" with no red X's or exclamation points and they were performing as high-speed ports before, so I guess my computer recognizes them as high-speed but they're just not performing as high-speed for whatever reason.

I have an ASUS CM5570 running Vista 64-bit SP2. I've tried downloading drivers for this model from the ASUS site, but only Windows 7 drivers are available. The motherboard I have is P5QL-VM EP and I have downloaded the chipset driver from the ASUS site but that has not fixed the problem.

I've tried different USB devices (iPods, EXT HDD's, etc) on all 8 ports and the message comes up every time.

I'm at a loss. Any help is GREATLY appreciated!

Luke_Vader is offline  
Old 11-30-2011, 06:40 AM   #2 (permalink)
Newb Techie
Join Date: Nov 2011
Posts: 1
Default Re: USB 2.0 not recognized as high speed ports

I've had the same problem, reset bios and everything including re-installing the drivers multiple times.

Also my sound decided to quit working on my ASUS CM5570 after a windows update, I was able to re-install the driver after installing, and uninstalling multiple times for about and hour. It quit again and after hours and hours I give up.

Was thinking of getting another sound card, now I'm thinking of getting another motherboard.

Unless there's some other people have the same issues as Luke_Vader and I.

I'm at a loss also. Any help is GREATLY appreciated!
anomaly146 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
More Ram/Low Speed OR Less Ram/High Speed alchemist007 New Systems | Building and Buying 1 09-26-2008 07:38 PM
Only a few USB ports working in high speed regeisle Hardware Repairs and Troubleshooting 2 08-09-2008 03:57 PM
High-Speed >> Dial-up ncjimn Off Topic Discussion 30 05-06-2006 12:49 AM
*High speed USB* TeCk_N Computer Audio and Multimedia 3 09-24-2004 09:05 AM
High Speed Internet abrock Off Topic Discussion 2 03-01-2003 03:40 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:22 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.