USB 2.0 Hi Speed - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 01-02-2007, 04:35 PM   #1 (permalink)
Newb Techie
Join Date: Jan 2007
Posts: 1
Default USB 2.0 Hi Speed

I just bought a Sabrent USB 2.0 VIA 4+1 Ports PCI Card. I put in the PCI card and it had an error when it tried to install the hardware and the driver it came with on a CD. So I figured it might be because my computer doesn't support hi-speed usb yet because I need to get the proper driver. It seemed as if the CD the card came with could install it for me but it says "Please update to windows xp service pack 1." Apparently I don't have service pack one so I'm going straight for service pack two. Currently the USB ports DO work but it says whenever I connect something to it "Hi speed device plugged into non-hi speed bla bla". Perhaps my card actually ISN'T high speed on all of the ports, I really can't tell because the packaging was really cheap and doesn't state that all of the ports are high speed. Anyway any help is cool and I really appreciate it!!


toysoulja is offline  
Old 01-02-2007, 09:05 PM   #2 (permalink)
True Techie
Join Date: Jan 2006
Posts: 105

google can go along way, and it is a hi speed usb card, If you have windows xp service pack 2 then it should already have the usb 2.0 drivers, so not sure why its saying its not

Intel Pentium 4 2.00Ghz FSB 400Mhz
MSI MS-6533 Motherboard
1 - Seagate 20Gb 1 - 40 gig Maxtor AND 1 Western Digital - 80 gig (Variety there eh)
Geforce 5200 128mb AGP
Liteon Dvd Burner
340watt PSU
schultzy is offline  
Old 01-02-2007, 11:30 PM   #3 (permalink)
There and Back again
Nukem's Avatar
Join Date: Jan 2005
Location: Virginia Beach
Posts: 4,334

you need to get all the windows updates. not just select ones... bypassing SP1 will cause certain fixes (prior to SP2) not to get fixed...go to windows update and let it get all the needed patches. then try to install the card again.

Dell 4K S2817Q / Logitech Z-680 / Func MS3 Mouse / Corsair K70
NZXT Source 530 / i7-3770K / Corsair H100 / ASRock Z77 Extreme4 / SoundBlaster Recon3d
Samsung 850 PRO 512GB SSD/Seagate 1TB/2TB/WD 2TB
4x4GB Corsair Vengeance 2133 / PNY GTX 980 ti/ Seasonic M12II 850W
Nukem is offline  
Old 01-03-2007, 01:36 AM   #4 (permalink)
Wizard Techie
Jorsoft's Avatar
Join Date: Feb 2004
Location: Oakdale, MN
Posts: 4,581

Nukem is right you'll need to download everything from Windows Update site. I think the driver disc you got has stuff only for Windows 2000 and 9x. Windows XP SP2 will have drivers for it already.

I think I actually bought a Sabrent usb 2.0 card a couple years ago for my old pc. Worked just fine and all ports were high speed.
Jorsoft is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:37 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.