Troubled PC - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-21-2006, 05:12 AM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2006
Posts: 1
Question Troubled PC

I turned off my pc for the night because the whole system was feeling slugish and slow. Then the next morning it wouldnt boot up at all. The green status light on the motherboard was on so it was getting power. I switched the power supply anyway and then it booted up, but nothing was showing up on the screen. I dont know where to start troubleshooting I really dont have another pc I can switch components with. My specs are Asus A8N SLI DELUXE, Athlon64 3200 939, NVIDIA 6600GT pci, 2x512 Corsairs xms, 74gb WD raptor, 200gb WD.

My thoughts are maybe the mobo died on me? the small fan on the bottom of the mobo stop spinning... I dont know how the PS could of gone bad when it was turned off...
__________________

x1andy is offline  
Old 03-21-2006, 07:29 AM   #2 (permalink)
Monster Techie
 
MrCoffee's Avatar
 
Join Date: Feb 2006
Location: UK
Posts: 1,858
Default

failing PSU could have damaged the mobo, but you might want to try resetting the bios before you get a replacement.
__________________
Intel core I7 920
GA-EX58-UD3R
6GB OCZ platinum 1600
XFX HD4890
Noctua nh-u12p
Corsair HX520
Antec 300
Samsung 1TB F1 Spinpoint
Samsung SM2443BW 24"
MrCoffee is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.