Sound Hardware issue - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-15-2008, 09:43 PM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2008
Location: Western Australia
Posts: 12
Question Sound Hardware issue

I have an annoying issue with using sound hardware acceleration that I have been unable to find a solution to.

I have a pci sound card, a sound blaster 5.1, and in certain games, like Battlefield 2, Oblivion and Fallout 3, the sound seems to echo when using hardware acceleration for the sound. In BF2 it's easy to remedy by simply switching to software for the sound. But there's no option for this in other games.

I'm kinda wondering why my sound card seems to have so much trouble with the sound in these games. The reason I bought it in the first place was to have a dedicated sound card so the processor wouldn't have to work as hard processing the sound.

Any Ideas on how to get Hardware acceleration working properly?
__________________

Anarion is offline  
Old 12-15-2008, 09:46 PM   #2 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Sound Hardware issue

Which OS? Which sound blaster?
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 12-15-2008, 10:04 PM   #3 (permalink)
Master Techie
 
eyeCpc's Avatar
 
Join Date: Apr 2007
Posts: 2,074
Default Re: Sound Hardware issue

It sounds like the EAX effects are enabled. In the audio console you place a check in the box as well as choosing which type like concert hall or auditorium when selecting the effect for any sounds assigned to functions in Windows. This problem comes up in XP far more then in Vista.
eyeCpc is offline  
Old 12-15-2008, 10:49 PM   #4 (permalink)
Newb Techie
 
Join Date: Feb 2008
Location: Western Australia
Posts: 12
Default Re: Sound Hardware issue

I'm running XP. EAX works fine under software mode incidentally, and turning it off under hardware does nothing to fix the problem.

Quote:
Originally Posted by Mak213
Which sound blaster?
Quote:
Originally Posted by me
I have a pci sound card, a sound blaster 5.1
Anarion is offline  
Old 12-15-2008, 11:00 PM   #5 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Sound Hardware issue

That doesnt answer the question. I have a Sound Blaster as well. But mine is a Audigy 2ZS. We need more info than a Sound Blaster 5.1 as there are many kinds of them.

Live? Audigy? X-Fi?

More info is needed!

Also have you checked for updated drivers?
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 12-15-2008, 11:02 PM   #6 (permalink)
Master Techie
 
eyeCpc's Avatar
 
Join Date: Apr 2007
Posts: 2,074
Default Re: Sound Hardware issue

You may need to install a EAX unified driver for the games themselves. Creative Worldwide Support

We missed each other's posts Mak. There are two 5.1 models in the SB line. SB 5.1 and SB 5.1vx Creative Worldwide Support > Sound Blaster
eyeCpc is offline  
Old 12-16-2008, 04:08 AM   #7 (permalink)
Newb Techie
 
Join Date: Feb 2008
Location: Western Australia
Posts: 12
Default Re: Sound Hardware issue

I've been looking into the EAx unified drivers but can't really find out much. Where can I find them?

As for the drivers, the latest ones, according to creative, are the ones that come on the driver cd supplied with the card.
Anarion is offline  
Old 12-16-2008, 05:12 PM   #8 (permalink)
Master Techie
 
eyeCpc's Avatar
 
Join Date: Apr 2007
Posts: 2,074
Default Re: Sound Hardware issue

The information at the Creative support site shows that the unified drivers are usually found on the game disk or at their own support site. Activision, 3DRealms, etc. You may end at those sites anyways to go through their faq/troubleshooting sections.
__________________

eyeCpc is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
POST Troubleshooting Guide SYL\X/3K Hardware Repairs and Troubleshooting 7 03-07-2009 11:24 AM
What To Look For When Buying Computer Components Luke Monitors, Printers and Peripherals 25 01-07-2009 09:09 PM
Yet another CPU hardware issue Gabb Hardware Repairs and Troubleshooting 10 11-01-2008 10:54 PM
Strange sound problems Low Sound/Popping Sound/LOUD sound DavidJC Computer Audio and Multimedia 2 05-20-2008 08:13 PM
Video not working - Hardware issue TorQueMoD Hardware Repairs and Troubleshooting 4 07-02-2007 04:54 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.