sd not recognized by windows explorer - NOT VISTA - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-05-2009, 02:19 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2009
Location: I travel constantly - base is in NC
Posts: 4
Red face sd not recognized by windows explorer - NOT VISTA

My dell latitude 430 simply will not recognize the SD drive. Have been on the phone with dell for 3 hours, they installed all their drivers. Went to Windows updates, installed three updates there, have uninstalled device, reinstalled it..........still shows up in device manager with an exclamation mark, and will not show in windows explorer when an SD card is inserted. It will, however, alert when the card is inserted. Just won't show up.

I am not running Vista - using Windows 2007. Have searched five forums and cannot find anything new to try.

Have tested 5 cards in 3 other machines and a camera - they work fine elswhere just not this notebook.

HELP have over 500 vacation pics from Scotland I need to download and post.

thanks so much.
__________________

Gennymac is offline  
Old 10-05-2009, 07:30 PM   #2 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: sd not recognized by windows explorer - NOT VISTA

Okay first, if it is showing the exclamation mark, that means you have the wrong drivers. You need the proper ones to get it to work.

Second what is Windows 2007? There is Windows XP, Windows Server 2008, Windows 7, Windows Server 2008 R2. There is no such thing as Windows 2007.
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 10-06-2009, 09:53 AM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2009
Location: I travel constantly - base is in NC
Posts: 4
Default Re: sd not recognized by windows explorer - NOT VISTA

My mistake - the operating system is Windows XP.

Do you have any idea where I can find the correct drivers, what naming convention might be used to identify the correct one? I've gone through Dell, and Microsoft, but have had no luck with either. I think I'm just missing the correct driver and don't know i t.

Newbies - takes us awhile to figure things out.

Thanks much for the help ! Any additional info would really be appreciated.
Gennymac is offline  
Old 10-06-2009, 09:57 AM   #4 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: sd not recognized by windows explorer - NOT VISTA

Well the best advice I can offer at this time would be to get something like Belarc Advisor, SiSandra Software or even Everest. This will allow you to get the exact make and model of the card reader. Give us that information and we can work on trying to find you the proper drivers.

I am guessing that it is a Flash Card Reader device right?
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 10-06-2009, 10:04 AM   #5 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: sd not recognized by windows explorer - NOT VISTA

If we are talking about a Latitude D430 then this should be the driver you need.

Drivers and Downloads
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 10-06-2009, 10:46 AM   #6 (permalink)
Newb Techie
 
Join Date: Oct 2009
Location: I travel constantly - base is in NC
Posts: 4
Default Re: sd not recognized by windows explorer - NOT VISTA

Ok, ran Belarc and this is what comes up in their report. I am a little confused, as this notebook comes with an SD drive for the small media cards, and a separate Smart Card insert for the larger cards for other communication uses. Am I correct that the SD drive doesn't really say which model etc is installed and the Smart Card entry is the Toshiba? Sorry, learning fast, but not there yet.

SD Memory Card [Hard drive] -- drive 1
TOSHIBA MK8009GAH [Hard drive] (80.03 GB) -- drive 0, s/n X77EW7APW, rev BS011G,

Thanks so very much for the help.
Gennymac is offline  
Old 10-06-2009, 12:02 PM   #7 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: sd not recognized by windows explorer - NOT VISTA

Did you check the drivers posted by Hefe? Might need to use something like Driver Sweeper to help clean out any old and unused drivers.

Guru3D - Driver Sweeper
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 10-06-2009, 03:33 PM   #8 (permalink)
Newb Techie
 
Join Date: Oct 2009
Location: I travel constantly - base is in NC
Posts: 4
Default Re: sd not recognized by windows explorer - NOT VISTA

I installed the driver that Hefe sent - ran the cleaner and still have the same result. When I right click on the the device in admin tools I see this in the description. 'This device cannot start. (Code 10)'

I am at a loss as to what to do now.

Any further suggestions?
Gennymac is offline  
Old 10-06-2009, 05:23 PM   #9 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: sd not recognized by windows explorer - NOT VISTA

Well the only other thing i can think of would be that the device isnt functioning properly. Which would require Dell to check on it.
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BSOD ERROR ON SISGRV.DLL hubbardukhh Hardware Repairs and Troubleshooting 10 09-08-2009 08:59 AM
Explore And Burn Integrates DVD Burning In Windows Explorer Osiris Tips, Tricks & Tutorials 0 08-21-2009 01:40 PM
Six Vista annoyances fixed in Windows 7 KSoD Microsoft Windows and Software 26 01-10-2009 03:10 AM
Windows "Workstation" 2008 Clobbers Vista in Benchmark Testing xXxexpertxXx Microsoft Windows and Software 9 03-09-2008 02:28 PM
The Vista Death Watch EricB Microsoft Windows and Software 112 11-20-2007 12:20 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.