Questions for Corsair 620W PSU - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-23-2007, 03:16 PM   #11 (permalink)
Retired.
 
peterhuang913's Avatar
 
Join Date: Dec 2005
Location: Los Angeles, California
Posts: 8,076
Send a message via AIM to peterhuang913
Default Re: Questions for Corsair 620W PSU

Quote:
Originally Posted by krazyq View Post
GOT IT! thanks
No problem
__________________

__________________


My computer uses 1.5A-load, .8A-idle, .65A-standby, .05A-turned off on 125V.
"The spaces between your fingers were created so that another's could fill them in."
Quote:
Originally Posted by Norcent View Post
I need to stop using the internet.
peterhuang913 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VCore won't go above 1.41v?? Is it my PSU? Alexinator Overclocking and Modding 8 09-10-2007 12:50 AM
huH? PSU huH? SHaTTaFaKKaP New Systems | Building and Buying 10 09-06-2007 08:48 AM
Lots of questions help.... pinoy3000 New Systems | Building and Buying 4 09-01-2007 02:28 AM
Two questions before pulling the trigger... Portland Newb New Systems | Building and Buying 12 08-16-2007 01:07 PM
A few questions on my new build [SF]MKM New Systems | Building and Buying 51 06-24-2007 05:43 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.