PSU/GFX Issue - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 02-12-2009, 04:44 AM   #11 (permalink)
Newb Techie
Join Date: Feb 2009
Posts: 12
Default Re: PSU/GFX Issue

I've ordered a new PSU and will replace it once I get it (500w) I hadn't actually looked before but noticed mine is only 375, I can't believe it's so low :S

Is there any possibility the motherboard could be fried? I wanted to avoid this cos I've already spent loads trying to fix it, I think I could of got a new PC after all this

Narzal is offline  
Old 02-12-2009, 07:28 AM   #12 (permalink)
Ultra Techie
AMDSCOrPiO's Avatar
Join Date: Jul 2006
Posts: 613
Default Re: PSU/GFX Issue

pop all the ram out and power it on, it should beep like crazy. If it doesn't then maybe its a motherboard issue.

Although its most likely the gpu, ram or psu can't hurt to rule out a motherboard issue. Also, if you have more than one stick of ram, try running the computer on one stick. Chances of both sticks going bad are slim.

AMDSCOrPiO is offline  
Old 02-12-2009, 07:50 AM   #13 (permalink)
Newb Techie
Join Date: Feb 2009
Posts: 12
Default Re: PSU/GFX Issue

Beat you to it :P I've tried with and without RAM, (I do have 2 sticks, tried alternate)

PSU and GFX Carrd on it's way so will fit them next week and hopefully that solves the problem.
I assume if it doesn't, it's definitely the motherboard?
Narzal is offline  
Old 02-12-2009, 03:31 PM   #14 (permalink)
Yee Ol' Salt
Hampton's Avatar
Join Date: Dec 2008
Location: USA
Posts: 642
Default Re: PSU/GFX Issue

So it was the same.. no post with the GPU out? or did it post? it sounds like the GPU my friend.


Find my post helpful? IF so please rate me by clicking the green check mark under my avatar.

:D Antec 300|M3N72-D|AMD PHM II X3 BE 720 3.0ghz (CodeName "Heka")|OCZ Stealth Xtreme 600w|2 two gig OCZ DDR2 1066 gold 4 GB of Ram|BFG-GTX 260 512||Samsung 42" Plasma| XP x86 sp3 /Vista x386 and x64|
The face I make everytime I'm on my machine :eek:
Hampton is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus M3A78-T Raid 5 Rebuild Issue Draconus Hardware Repairs and Troubleshooting 4 11-11-2008 02:22 PM
Funky Audio Issue Lexluethar Computer Audio and Multimedia 11 09-17-2008 02:32 PM
Crysis 1.2 patch dario03 PC Gaming 34 08-29-2008 01:42 AM
Seeminly Unsolveable Problem! Reply ASAP! yoshi1476 Microsoft Windows and Software 44 06-12-2008 11:48 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:16 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.