PSU is dead - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-18-2005, 01:33 AM   #1 (permalink)
Banned
 
Join Date: Dec 2005
Location: in the past
Posts: 1,144
Send a message via AIM to thebleakness
Default PSU is dead

I bought a OCZ powerstream 520W psu and it came in today. I had everything setup correctly and it wouldnt boot. Two LEDs came on and that was it. I messed with it forever and nothing worked so i tried the psu that came with the Xion II case. It booted up immediatly. Is the powerstream defective or am i forgetting to set something? Thanks for the help.
__________________

thebleakness is offline  
Old 12-18-2005, 02:45 AM   #2 (permalink)
Memberbot
 
Elbatrop1's Avatar
 
Join Date: Mar 2004
Posts: 4,057
Default

Have you made sure that the switch that determines what voltage you use is set correctly?

Also, I found with my MOdStream that sometimes the connectors were kinda crappy, and that I would have to really make sure that they were nicely secured. Try using different cables to connect things up.
__________________

__________________

Intel E6750...........PSN: ELBATROP
XFX nForce 650i Ultra
Patriot PC2-6400 8GB (4x2GB)
eVGA 9800GT
36GB WD Raptor
120GB SG
1TB SG
Logitech X-530
Samsung SyncMaster 931c
Samsung SyncMaster 750s
Windows 7 Home Premium 64
Elbatrop1 is offline  
Old 12-18-2005, 02:51 AM   #3 (permalink)
Banned
 
Join Date: Dec 2005
Location: in the past
Posts: 1,144
Send a message via AIM to thebleakness
Default

Ive tried everything. The voltage switch to 115v like it says in the manual. Changing the cables did zilch. This really sucks because im at a standstill because my old psu doesnt have enought power connectors. I have pmed a OCZ tech guy to see his thoughts on the matter and if he doesnt have any im going to RMA it.
thebleakness is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.