Problems with the current and my psu - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 11-20-2005, 05:48 PM   #21 (permalink)
Newb Techie
Join Date: Nov 2005
Posts: 12

some1 told me that the capaciters on the board are usually first to go...

one is a little rounded at the top but the others look fine...

my black ones look ok. the 2 green ones look good but the one yellow looks a little iffy...

those are the ones with the wires wrapped around them. the yellow capaciters wires are buldged and the wire is a bit farther away from the capaciter.

all of the cylinder cap. have flat heads and look ok.

k, the ones on the left on the picture are bad, mine look good.
the one on the far right looks like mine in the picture, but the wires wrapped around are a little swollen, so how much bulging of the wires is tooooo much?

Dilly man 2 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.