Problem With my Graphics Card!!! Please Help - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-01-2014, 08:00 AM   #1 (permalink)
Newb Techie
 
Join Date: Nov 2013
Location: England
Posts: 21
Exclamation Problem With my Graphics Card!!! Please Help

Recently built my own computer with z87 Extreme4 motherboard and Asus Readeon R9 280x Graphics Card.
when i went to install my graphics card drivers an error message kept coming up saying 'Please install VGA cards of asus.' i went to check my system browser in the bios and according to that, my pci e slot is empty when i can see through the side window my graphics card in place, with fans spinning and led's lit up. i have taken it out and inspected it but all seems to be fine, i have made sure it is fully pressed in and the cap is on but nothing seems to be working for me.
Is this a fixable problem or do i need to replace my Graphics Card??
Any help is appreciated, Thanks
__________________

bjwphneb is offline   Reply With Quote
Old 02-01-2014, 10:04 AM   #2 (permalink)
Monster Techie
 
acerinpa's Avatar
 
Join Date: Jan 2009
Location: USA
Posts: 1,838
Default Re: Problem With my Graphics Card!!! Please Help

Do you have the MOBO PCI -e "enabled" in the bios set up ? I believe this has to be done when you boot up and get into the bios that way ( pressing F5 or F8 - depending on the motherboard) before windows screen - not thru the browser. Have you downloaded/updated the Bios, directX, etc. - usually the drivers/software that comes on the CD with the MOBO are old.

Does the PC boot up and work well without the GPU installed? What CPU are you using?

I am just learning to help people - others will chime in that can give additional help.
__________________

acerinpa is offline   Reply With Quote
Old 02-01-2014, 10:24 AM   #3 (permalink)
Newb Techie
 
Join Date: Nov 2013
Location: England
Posts: 21
Default Re: Problem With my Graphics Card!!! Please Help

yeah i have it all enabled in the bios, pressing f11 on start up. i have all the windows updates, haven't got all the motherboard updates yet. i have intel i5-4670K cpu. and i am on the computer now and the gpu isn't installed or so the computer claims. so yeah it works fine for doing standard computer stuff but when it comes to games it won't be able to run on full graphics as it will only be running on the crappy onboard graphics card. i'm going to try installing it into a different pci slot to the one i have it in and see if that has any affect.
cheers for the response though
bjwphneb is offline   Reply With Quote
Old 02-01-2014, 12:38 PM   #4 (permalink)
Monster Techie
 
acerinpa's Avatar
 
Join Date: Jan 2009
Location: USA
Posts: 1,838
Default Re: Problem With my Graphics Card!!! Please Help

Sounds like the problem is in the mobo not "seeing" the graphics card = PCI slot is not enabled - even though it says it is. Are you using the Intel software that is supposed to allow you to use the on-board graphics and a separate graphics card at the same time - if yes- then disable it and maybe the system will now "see" the graphics card. Also if using WIn7 - check in the my computer/ system properties/ device manager - to see what drivers are installed, chip set is installed, etc. If your using Win 8 - then I cannot help in this regard as I know nothing about win8 .
acerinpa is offline   Reply With Quote
Old 02-01-2014, 01:53 PM   #5 (permalink)
True Techie
 
Join Date: May 2011
Location: SC
Posts: 235
Default Re: Problem With my Graphics Card!!! Please Help

Are you connected to the on-board graphics when you try to install the Graphics driver? If so you need to connect to the GPU for displaying. If you connect to the on-board graphics and not the GPU it may be acting as it is not installed since it is not be used. Try booting with only being connected to your GPU and not the on-board.
bpm55 is offline   Reply With Quote
Old 02-01-2014, 01:58 PM   #6 (permalink)
Newb Techie
 
Join Date: Nov 2013
Location: England
Posts: 21
Default Re: Problem With my Graphics Card!!! Please Help

nothing shows up on the screen when i plug it into the hdmi slot on the graphics card
bjwphneb is offline   Reply With Quote
Old 02-01-2014, 02:00 PM   #7 (permalink)
True Techie
 
Join Date: May 2011
Location: SC
Posts: 235
Default Re: Problem With my Graphics Card!!! Please Help

Does the card show up in the bios? Do you have the power plugged into the GPU? The card will get enough power from the pci-e slot to run the fans and appear operational, but it needs supplemental power to actually power all the way way on. Near the back end of the card are two power slots that need to be connected to fully run.
bpm55 is offline   Reply With Quote
Old 02-01-2014, 02:55 PM   #8 (permalink)
Newb Techie
 
Join Date: Nov 2013
Location: England
Posts: 21
Default Re: Problem With my Graphics Card!!! Please Help

There are two power sockets on the gpu. One 6 pin and one 8 pin. I've tried it with both plugged in I've tried it with just one plugged in
bjwphneb is offline   Reply With Quote
Old 02-01-2014, 03:01 PM   #9 (permalink)
True Techie
 
Join Date: May 2011
Location: SC
Posts: 235
Default Re: Problem With my Graphics Card!!! Please Help

can you post specs of your whole rig?
bpm55 is offline   Reply With Quote
Old 02-01-2014, 03:06 PM   #10 (permalink)
Newb Techie
 
Join Date: Nov 2013
Location: England
Posts: 21
Default Re: Problem With my Graphics Card!!! Please Help

Z87 extreme4 motherboard
Intel core i5-4670k CPU @3.40Ghz
8GB of ram
Windows 8.1 os
Asus Radeon r9 280x gpu
Seasonic 620w PSU
1tb hdd
__________________

bjwphneb is offline   Reply With Quote
Reply

Tags
asus radeon r9 280x, gpu, motherboard, not working, problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics card problem, please help ! tahiruddin System Upgrades 2 09-21-2011 06:58 PM
Please Help! Please Help! Please Help! thebeliever Viruses, Spyware and Malware 7 12-27-2010 11:00 PM
graphics card problem? help a noob please sugashane19844 Hardware Repairs and Troubleshooting 3 09-16-2009 11:07 PM
Installing graphics card problem, please help! jonny_uk Hardware Repairs and Troubleshooting 1 06-11-2008 04:45 PM
Graphics anomaly, but not graphics card problem parsona Hardware Repairs and Troubleshooting 7 10-12-2006 01:15 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.