problem mating my sonata psu cable with gigabyte 81875 power - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-29-2006, 12:52 PM   #1 (permalink)
Master Techie
 
Join Date: Mar 2004
Posts: 2,069
Default problem mating my sonata psu cable with gigabyte 81875 power

Hello

I mated my antec sonata case with my gigabyte 81875 ultra mobo. the problem was connecting the psu from the sonata to the mobo's power connector.

the connector did not fit, and i had to slant it in and with the use of a screw driver, push the electrical pins from the psu's connector in one by one.

it worked, but now i am afraid of removing the connector from the mobo since it was a pain, rather a mission and half to mate the electrical connections.


can you guys tell me why this happened, has it happened to some one before, what is the solution. can i remove the connecor and then fit it again with no problem next time?
rookie1010 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.