Problem launching Windows - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-27-2014, 09:23 PM   #11 (permalink)
True Techie
 
bigdog33's Avatar
 
Join Date: Aug 2011
Location: Minnesota
Posts: 184
Default Re: Problem launching Windows

Quote:
Originally Posted by Atomicman119 View Post
Corsair HX 750, and yeah the 750 was only 10 bucks more then the 650, so why not.

Good choice there.
__________________

bigdog33 is offline   Reply With Quote
Reply

Tags
blue screen, hard drive, windows error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Siren sound and problem with launching... pemu Hardware Repairs and Troubleshooting 0 09-11-2005 09:26 AM
AMD launching dual core Athlons tomorrow Trotter Monitors, Printers and Peripherals 22 04-21-2005 10:29 AM
windows media player not launching kad Microsoft Windows and Software 3 11-05-2004 12:24 AM
Outlook 2003 opens two browsers when launching hyperlink Rivet Head Microsoft Windows and Software 3 10-04-2004 02:54 AM
Remote Application Launching beedubaya Computer Networking and Internet Hardware 3 06-28-2004 01:11 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.