>> Problem << ATI Radeon 9550 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 11-10-2005, 10:59 PM   #1 (permalink)
Newb Techie
Join Date: Nov 2005
Posts: 7
Default >> Problem << ATI Radeon 9550


Radeon 9550
256 MB
AGP x8

O/S: Windows XP: Home edition (SP2)
AMD Athlon 2.08 GHz
MoBo: Asus A7V8X-X
512 MB RAM

Should be enough info there, now onto the actual problem and how it all started.

I bought this lovely Radeon today, I got home and excitedly installed the hardware, removing my old stinky Hercules Prophey KYRO Series 4000XT and all of it's related software (except one thing named KYRO inthe add remove software thing, but I removed the drivers and stuff...)

Extra info:

Error message when trying to un-install that KYRO thing is...

Anyways, I try installing the software for my new ATI 3D card...

Actions taken
Start > run... > D:\atisetup

ATI window

Display Adapter Driver Setup > Hydravision Install

(Now I figure this is for dual monitors but I'm not 100% so I'm posting this info anyways)


I also thought perhaps this would be for using the S-Video with my television which I plan on doing...

So now...

Display Adapter Driver Setup > Easy Install > Custom Install > Install all components...


So instead of installing all components I try express install, with yet again, the same error.

My next course of action took me to booting into safe mode. Here I ran the New Hardware Wizard and installed the card there, which ran rather smoothly. After doing this I booted back up into normal mode, and tried installing the Easy Install again (Because it wasn't showing the Display tabs in the advanced display options it was supposed to be) And received that same error...

I got frustrated but to no avail, at least the card worked, since I could play the games that I couldn't with my KYRO card. I began playing Lineage 2: Chronicle 3, on a free server. (please do not inquire as to which unless it is absolutely necessary, it is a private server.) While playing the game, my computer re-booted on me.... (I'm assuming it over-heated or something, I'm getting a fan for the card soon.) So I ran the game again, playing for a matter of 1 minute MAX, when I get this error (exits the game and gives it)...

Originally Posted by Error
OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 2073 MHz with 511MB RAM
Video: RADEON 9550 (6497)

General protection fault!

History: ULevel::CompactLevelObjects <- ULevel::CleanupDestroyedLevelObject <- ULevel::CleanupDestroyed <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- UpdateWorld <- MainLoop
So with that, I un-installed L2 to be sure it wasn't a problem there, deleting all registry entries for it, and the server files. I then proceeded to do a complete re-install of the game and it's server files. This seemed to work, because I was able to play for a while again, (got the re-boot here again) and I tried once again... Once I got going I received the same error again within a small amount of time, so I called up ATI product support, where I was told to download the latest driver. I did that, and am now stick with this error, while trying to install the new driver.... (Removed all previous files btw, so the card is no longer installed on my system)

My resolution? Go to Safe mode, and run the Add New Hardware Wizard, this time, instead of taking the drivers from the CD, browsing for the driver I downloaded; now, my only problem is, the Hardware Wizard won't detect my 3D card!!!!!

Frustrating indeed!!!

I know this has been a long post, but it should prevent people suggesting things that I have already done.

Thank you for your time,


aka. Tyrone Lamoureux
OneRyt is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:55 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.