Problem... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 06-13-2008, 10:11 PM   #1 (permalink)
Newb Techie
 
Join Date: Jun 2008
Posts: 4
Default Problem...

I have a weird heatsink which i'm having trouble removing. It's a AVC heatsink, with stainless steal clips, or grips. I'm not sure. I've tryed alot of things, pushing it down, up, left ect.. How do i remove it!? Here's a picture..

I'm upgrading to a Intel Core 2 duo, 2.4 ghz, from my intel pentium 4 3.06ghz.


YouNMe1 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with 3D graphics mordi05 Microsoft Windows and Software 6 12-10-2007 11:37 PM
Serious computer problem. HeeRoMaKi Hardware Repairs and Troubleshooting 71 07-28-2007 11:42 PM
Media Library (I Presume) Problem. Nadegas Microsoft Windows and Software 4 06-08-2007 08:27 AM
cant find the problem... Jhill1 Hardware Repairs and Troubleshooting 13 05-07-2007 04:51 PM
Chronic Rebooting Problem AND_YOU_ARE Hardware Repairs and Troubleshooting 1 04-24-2007 06:04 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.