Powercut killed my computer? - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-12-2006, 01:28 PM   #11 (permalink)
I know things...
 
wicked23's Avatar
 
Join Date: Jun 2006
Location: Pennsylvania
Posts: 398
Default

Please clarify. is your pc actually not turning on? From your first post all i got is the light blinks too much.
__________________

__________________
"Research is what I'm doing when it looks like I'm not doing anything" :D

BEER, is it in you?
wicked23 is offline  
Old 12-13-2006, 12:00 PM   #12 (permalink)
Newb Techie
 
Join Date: Dec 2006
Posts: 35
Default

Hehe good point!

Yeah it doesn't turn on at all. Doesn't even make any form of starting-up noise
__________________

Danjb is offline  
Old 12-14-2006, 01:06 PM   #13 (permalink)
Newb Techie
 
Join Date: Dec 2006
Posts: 35
Default

Bump
Danjb is offline  
Old 12-14-2006, 01:19 PM   #14 (permalink)
Super Techie
 
Join Date: Nov 2006
Posts: 421
Default

I once had this and it turned out that there was indeed a short in the power button. I got it replaced for a few bucks and it worked again.
Phrantic is offline  
Old 01-01-2007, 05:58 PM   #15 (permalink)
Newb Techie
 
Join Date: Dec 2006
Posts: 35
Default

Eek, looks like I forgot to tell you guys!

I got a new power supply unit after checking with my bro's and it works. It was cheap
__________________

Danjb is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.