Power switch on-off does not work. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 03-27-2006, 11:22 AM   #1 (permalink)
Newb Techie
Join Date: Mar 2006
Posts: 10
Default Power switch on-off does not work.

I was trying to add a RAM module in a free slot. But as all the wires connecting the SMPS with mobo, hard disc etc were cluttering up the space above the RAM slot, I moved the wires this way and that to make room for the RAM. But now when I try to switch the machine on, it refuses to work. I mean, when I press the switch on, I can see system getting powered, but the switch does not stay locked in on position. What could be the problem?
devips is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:10 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.