Power supplies go pop - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-19-2005, 03:54 PM   #1 (permalink)
Newb Techie
 
Join Date: Sep 2005
Posts: 3
Default Power supplies go pop

I have an intel celeron 2ghz computer which stopped working at weekend after some deduction I worked out that the power supply had blown. so I replaced it with on of the same wattage and type. guess what it's blown again.Can anyone help with the fault finding process in working out why the PSU has blown for a second time

regards t
__________________

tony0808 is offline  
Old 09-19-2005, 06:13 PM   #2 (permalink)
Newb Techie
 
Join Date: Sep 2005
Posts: 3
Send a message via AIM to drob
Default

dude that sux =\

if you have another psu? try pluging everything in cept. for the24 pin and see what happens

look and see if the voltage is set to 115 and not 230
__________________

drob is offline  
Old 09-20-2005, 01:45 AM   #3 (permalink)
Ultra Techie
 
Join Date: Jan 2004
Posts: 769
Default

thats exactly what happend to me.

Last month my PSU blew.. brought another on and last week that one blew... now i have a more powerful PSU... hopefuly im safe...
__________________
Sprooty is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.