PC posts but no display - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 06-10-2007, 06:24 PM   #1 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 7
Question PC posts but no display

I've been having this on-going issue where when I turn on my pc, it never brings the monitor out of stand-by. After a long series of troubleshooting steps, I've had my video card, motherboard, and RAM replaced by their respective manufacturers. My monitor has a vga cable but my video card is dvi. Prior to replacing my video card i switched between two vga-dvi adapters that had previously worked fine. Upon replacement I received a new one from the manufacturer that still did not work. I tried using a different monitor with the adapters but it still did not work. I also used my monitor on a different pc w/o the adapters and it worked. I find it hard to believe that all 3 adapters do not work. At this point, I am at a loss. Anyone that can help will have my greatest thanks.

My system specs are as follows:

Asus P5N32 SLI-Deluxe
Pent-D 930 3.0Ghz
OCZ 2x1GB 667mhz DDR2 RAM
XFX GeForce 8600 GTS 256MB
Coolermaster 600W PSU
Windows XP Pro

futility is offline  
Old 06-10-2007, 06:26 PM   #2 (permalink)
peterhuang913's Avatar
Join Date: Dec 2005
Location: Los Angeles, California
Posts: 8,076
Send a message via AIM to peterhuang913
Default Re: PC posts but no display

does the video card require a 12v attached to it?


My computer uses 1.5A-load, .8A-idle, .65A-standby, .05A-turned off on 125V.
"The spaces between your fingers were created so that another's could fill them in."
Originally Posted by Norcent View Post
I need to stop using the internet.
peterhuang913 is offline  
Old 06-10-2007, 06:36 PM   #3 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 7
Default Re: PC posts but no display

Yes and it is connected. My system is definitely not underpowered.
futility is offline  
Old 06-10-2007, 07:14 PM   #4 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 9
Default Re: PC posts but no display

u try to reinstall windows ?
aaron_mcd is offline  
Old 06-11-2007, 07:36 AM   #5 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 7
Default Re: PC posts but no display

since the monitor wont come out of stand-by, i cant see anything to install/reinstall
futility is offline  
Old 06-11-2007, 07:58 AM   #6 (permalink)
Lord Techie
Nitestick's Avatar
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473
Default Re: PC posts but no display

if the monitor does not power up reinstalling windows won't help anyway. it would seem that your PC is stalling during POST, unless you can confirm that windows loads (either by speakers or HDD activity). use a known good memory stick, try it in all slots. also try resetting your CMOS (for some reason this occasionally fixes problems like this). if possible i also recommend trying a PCI video card. for troubleshooting purposes you are probably best off to remove all unnecessary cards and drives. if nothing helps then you're probably looking at a dead motherboard (could be processor though). if it works, start adding hardware back until the issue repeats (if it does you found the culprit, if not then it was a configuration problem).
Visit my website - nitestick.net
"Guitar is cool. If you donít think the guitar is cool, then youíre stupid. And I will fight you! " - Brendon Small
I'm sorry but I do not accept support requests via IM, email, or personal messages
You can contact me for Forum related issues via PM only.

Nitestick is offline  
Old 07-08-2007, 10:43 PM   #7 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 7
Default Re: PC posts but no display

Sorry its been a while. I kinda wanna strap maybe 12lbs of C4 to this thing and send it on its way...

Ok so I listened for start up music and nada. I kinda noticed that i cant even press any of the locks on my keyboard (caps, etc). resetting cmos used to fix it way back when, then i started having my current problem. i've swapped the ram, even had the manufacturer replace them. current card is pci ex. there are two slots 'n i've tried them both. the only things that have been connected for a while now are only the ram, psu, v-card, and cpu... the pc should bring up the bios even w/o the cpu (which it doesnt). a recent suggestion was that it could be the psu, so that just got replaced and nothing

all in all, the motherboard, ram, psu, and vid card have been replaced by either me or the manufacturer.....
futility is offline  
Old 07-08-2007, 11:53 PM   #8 (permalink)
disgruntled ex-moderator
Nagasama's Avatar
Join Date: Oct 2006
Location: probably on the lake
Posts: 6,956
Default Re: PC posts but no display

by deduction, that would leave the processor. i dont know that the bios would display without the cpu, i am not sure about that.
"nagasama no longer drinks tecate, or streaks out of the night for anything, and he has a fine wife so he has no use for your girlfriend...she is safe..."
Nagasama is offline  
Old 07-14-2007, 07:08 PM   #9 (permalink)
Newb Techie
Join Date: Jun 2007
Posts: 7
Default Re: PC posts but no display

I suppose you're right. I've ****ed away enough money into this pc. I guess a new processor wont hurt. I'll follow up after I get it...
futility is offline  
Old 07-17-2007, 01:26 AM   #10 (permalink)
Junior Techie
Join Date: Sep 2006
Posts: 73
Send a message via AIM to freedonutss
Default Re: PC posts but no display

Yep, Its your processor. Awhile back I received a faulty processor and everything powered up but no signal to the monitor. That would be it my friend.

Aspire X-Navigator Series
Intel 3.66 Ghz Dual Core
2x 1GB Kingston 4-4-4-12 Ram
ECS P4M890T-M2 LGA 775 M/B
Nvidia Geforce 7900GTO 512 MB PCI x16
Rosewill 700W PSU
Seagate Barracuda 250GB 16MB 3.0gb/s
freedonutss is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Build Won't Display ANYTHING mvpo.geo Hardware Repairs and Troubleshooting 8 07-17-2007 01:19 AM
PC posts but no display futility Hardware Repairs and Troubleshooting 0 06-10-2007 05:47 PM
windows 2000 server display problem hiren Computer Networking and Internet Hardware 2 06-04-2007 12:31 AM
Widescreen Display (16:9) with Nvidia GeForce 7300le?? discoverydrafting Hardware Repairs and Troubleshooting 0 04-26-2007 03:43 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.