pc issue - fried mobo? weak psu? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 01-17-2010, 11:21 AM   #1 (permalink)
Newb Techie
Join Date: Jan 2010
Posts: 1
Default pc issue - fried mobo? weak psu?

hey got an issue, not particularly adept at pcs but ill post what tests ive tried to run

tried to install a wd500gb slave hd yesterday
booted up fine and then about to format at disk management (/w Win7)
as soon as i clicked 'ok' to begin formatting, pc shuts down

i got kind of worried at this stage so i ran a series of tests
can turn on but turns off after 6-7s and no display
the next morning, the computer remains turned on but no display
so i guess the psu is fine, or it is really weak

after i thought maybe my old hd was fried so i plugged the new hd as master drive but same result

i did notice the fan on top of the mobo heatsink was running slow, if not, not running at all so maybe the mobo might be fried?

thanks for your input!
i appreciate it

p.s. i want to add that i tried running without any hd plugged in and same result occured (pc turns on but no display)

roarixer is offline  
Old 01-17-2010, 12:06 PM   #2 (permalink)
Super Techie
iPROTechman's Avatar
Join Date: Dec 2009
Location: Manchester
Posts: 334
Send a message via MSN to iPROTechman
Default Re: pc issue - fried mobo? weak psu?

Cpu could be burned out im guessing due to you saying about the fan.. Could be a bad card/Board, Try the elimination process.

barebone your pc, try 1 stick of ram at a time, in both slots etc. If this doesn't work test your hardware in a test rig or test a new cpu/board in yours.
iPROTechman is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
PSU or Mobo Trevon Hardware Repairs and Troubleshooting 15 07-25-2009 06:40 PM
Crysis 1.2 patch dario03 PC Gaming 34 08-29-2008 01:42 AM
Computer won't boot/ no video. Possible MOBO issue. gangsta99 Hardware Repairs and Troubleshooting 4 04-04-2008 11:44 PM
VERY strange PSU issue.... c0rr0sive Hardware Repairs and Troubleshooting 0 01-17-2008 08:03 AM
Question regarding mini ITX and recommended PSU 96300NAZ New Systems | Building and Buying 0 12-16-2007 09:29 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.