PC Don't do anything after Power it on - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 02-01-2007, 12:27 PM   #1 (permalink)
Ultra Techie
Phanto's Avatar
Join Date: Sep 2005
Location: Puerto Rico
Posts: 603
Default PC Don't do anything after Power it on

Hi all,

Today when I got home from college I went to obviously turn my PC on like I always do but this time something goes wrong. When I press the Power buttomg the computer start fine but after I press the buttom the computer start making like a long beep, and it continue doing the same over and over unless I turn off the PC. This is the first time that something like that happend to my PC, yesterday I use my computer like any other day without a problem.
I tried to check the manual of the mobo but it doesn't said a thing I even check their website and don't find anything that could help me out heck I couldn't even found the model of my MOBO (is already "discontinued")

The model of my mobo is down below.

Any help would be appreciate honestly, I was invited to a Lan Party of one of my brother's friend since it was announced one month ago I was really looking forward to go, maybe some of you guys know how I feel right now.

Thnx in advance.

Alex Orton

i5 2500k @ 4.5GHz
COOLER MASTER Hyper 212 Plus
MSI Z77A-G45
16GB Corsair Vengeance LP DDR3 1600MHz
Corsair HX650w
eVGA 670 GTX 2GB
Samsung 840 Pro SSD 256GB
Seagate Barracuda 7200.14 3TB
ASUS VG248QE Black 24" 144Hz, Samsung 24" S24B300, Samsung 22" 226BW & HP L1908W 19" (Quad Monitor Setup)
Phanto is offline  
Old 02-01-2007, 12:46 PM   #2 (permalink)
Do not Stare at my Avatar
Ste's Avatar
Join Date: Aug 2005
Location: Upon Gleaning Infinity
Posts: 9,571
Send a message via MSN to Ste

Im not going to go searching for the beep error but it probably is one of the following.
Bad Videro Card
CPU bad
BIOS or Board Currupt.

Dissconnect everything except RAM, CPU and video card. Then turn on and see if it POST's. If it does. Then repeat the process by reconnecting one piece of hardware each time and turning on to see if it POST's.
If it does not POST with just RANM, CPU and video card it means one of the 4 things above. You should then start by replacing each Component with Known good ones until it POST's once you find which component it is, replace it.

Ste is offline  
Old 02-01-2007, 12:46 PM   #3 (permalink)
Wizard Techie
Join Date: Jan 2005
Location: Delaware
Posts: 3,475

1 long beep usually means that there is a problem with your graphics card.
turtile is offline  
Old 02-01-2007, 02:47 PM   #4 (permalink)
I know <html>, do you?
SYL\X/3K's Avatar
Join Date: Aug 2006
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K

P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:08 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.