PC DOESN'T BOOT! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-03-2010, 04:59 PM   #1 (permalink)
Junior Techie
 
Join Date: Feb 2010
Location: In a House....
Posts: 59
Exclamation PC DOESN'T BOOT!

HI everyone,

Yesterday I accidentally removed the plug of my PC while it was on. Today I tried to start my PC, it got stuck at the boot- screen.

Any suggestion, maybe a damaged BIOS?
__________________

PurpleGorilla is offline  
Old 07-03-2010, 05:00 PM   #2 (permalink)
Hyper Techie
 
Abstract Hero's Avatar
 
Join Date: Apr 2010
Location: Phoenix, AZ
Posts: 1,842
Default Re: PC DOESN'T BOOT!

Quote:
Originally Posted by PurpleGorilla View Post
HI everyone,

Yesterday I accidentally removed the plug of my PC while it was on. Today I tried to start my PC, it got stuck at the boot- screen.

Any suggestion, maybe a damaged BIOS?
Have you tried resetting your bios?
__________________

__________________
- AMD FX8320 @ 4.2Ghz - ASRock Fatal1ty 990FX Killer - G.Skill Ripjaws X 8gb -
- Asus Strix GTX 970 - Corsair Neutron GTX - Corsair TX 750 -
- Cooler Master HAF XB - Corsair H105 -
- Asus VG248QE - Corsair M60 & K90 -
Abstract Hero is offline  
Old 07-04-2010, 11:19 AM   #3 (permalink)
Junior Techie
 
Join Date: Feb 2010
Location: In a House....
Posts: 59
Default Re: PC DOESN'T BOOT!

I did, now my computer will not start at all.... what to do next?
PurpleGorilla is offline  
Old 07-04-2010, 11:58 AM   #4 (permalink)
Lord Techie
 
Slaymate's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 7,946
Default Re: PC DOESN'T BOOT!

I would try a different power supply 1st.
__________________
[SIGPIC][/SIGPIC]
Slaymate is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista boot troubles tigerfootball05 Microsoft Windows and Software 1 11-15-2009 10:04 PM
Installed new motherboard - 'reboot/select proper boot device/insert boot media' prob raykwok Hardware Repairs and Troubleshooting 9 09-27-2009 03:25 AM
Vista won't boot without CD tigerfootball05 Microsoft Windows and Software 1 05-09-2009 08:42 PM
10 Ways To Make Linux Boot Faster Osiris Linux Tips and Tricks 0 08-04-2008 09:36 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.