Old laptop Motherboard. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Thread Tools Display Modes
Old 10-11-2014, 10:10 AM   #1 (permalink)
The Residential Loon
Spud1200's Avatar
Join Date: Nov 2010
Location: England, UK
Posts: 1,666
Default Old laptop Motherboard.

I have an Old Laptop motherboard and I'm curious as to why I cant get a Picture from the VGA Port it self. I have installed the RAM, and Connected everything such as the Monitor and the Charger Pack. Everything is booting but their is just No picture. I'm not sure if it need a BIOS Update, and I don't have the Original Screen for the laptop it self. to connect it proper. Even if I don't install the HDD and DVD RW drive I should be able to Post on it but their is just no Image on the Monitor.

Has anyone any Ideas as to what could be wrong or if its a BIOS update I need.

Spud1200 is offline   Reply With Quote
Old 10-11-2014, 11:20 AM   #2 (permalink)
Private Joker
carnageX's Avatar
Join Date: Feb 2007
Location: South Dakota
Posts: 23,150
Default Re: Old laptop Motherboard.

What OS is it running?

Did you enable the 2nd monitor in the Display Properties?

Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5

If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 10-13-2014, 03:30 PM   #3 (permalink)
The Residential Loon
Spud1200's Avatar
Join Date: Nov 2010
Location: England, UK
Posts: 1,666
Default Re: Old laptop Motherboard.

I cant get a Picture on the Monitor let alone Boot in to the BIOS, or to an OS. I don't have the original screen for it and when connecting the Power and Charger, Installing the Memory and HDD, and DVD RW Drive as in you would test a PC before installing the components in a Chassis, The whole System is giving no output.
Spud1200 is offline   Reply With Quote

bios update, hack, laptop, motherboard, repairs

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
old laptop dead, can i use old product key on new pc? zaka100 Microsoft Windows and Software 1 01-06-2014 11:02 AM
Adding an old fan to an old PC john3 Overclocking and Modding 5 03-19-2006 05:24 PM
WTB Old Old Comp/parts foreverxyoung Buy/Sell/Trade and Hot Deals 7 02-16-2006 04:09 PM
Old school laptop, lookin' for old school linux CntdwnToExtn Linux and Open Source 6 07-06-2005 06:16 PM
how old is too old? overclocker Monitors, Printers and Peripherals 28 05-10-2005 08:23 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:07 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.