Odd screen problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 07-07-2006, 08:30 PM   #1 (permalink)
Monster Techie
Ridlyn's Avatar
Join Date: May 2005
Posts: 1,920
Default Odd screen problem

This is a compac presario 2000, and when my bro turned on his comp the screen looked funny just like i took a pic, the color of the background still appears but very faintly.


My guess is that monitor is just ****ed.

AMD Turion 64 1.7Ghz
ATI Express 200m 128mb of shared memory
256mb of ram
60gb hdd
Originally Posted by Sylus View Post
Could have been worse, you could have been raped by a clown.
Ridlyn is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.