Odd Fuzzly Stuff.... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-22-2006, 02:08 AM   #1 (permalink)
Newb Techie
 
Join Date: May 2006
Posts: 9
Default ATI Radeon X9600 Problems

I had an Nvidia GeForce FX 5500 (lol) and I found a ATI Radeon X9600 (I think) in one of my older computers. I realised that my old one was better than my latest one so I plugged it in. Ever since then there has been this wierd fuzzly stuff on some icons, pictures and graphics. I'll post some screenies.


Fuzzly stuff in Blender:

Fuzzly stuff in start menu:

Fuzzly stuff on IE:

There is also some fuzzly stuff on my desktop icons and also sometimes in Oblivion all these add, seemingly 3D polygons flow out of the character and it's wierd and scary.

Does anybody know whats wrong?
__________________

Renegade222 is offline  
Old 05-22-2006, 02:45 AM   #2 (permalink)
Newb Techie
 
Join Date: May 2006
Posts: 9
Default

Anyone?
__________________

Renegade222 is offline  
Old 05-22-2006, 06:13 AM   #3 (permalink)
Newb Techie
 
Join Date: May 2006
Posts: 9
Default

Bump. Gr.
Renegade222 is offline  
Old 05-22-2006, 07:07 AM   #4 (permalink)
Wizard Techie
 
CrazeD's Avatar
 
Join Date: Feb 2006
Location: Maine
Posts: 3,736
Send a message via AIM to CrazeD Send a message via MSN to CrazeD
Default

Drivers?
__________________

Intel Q9400 | Gigabyte EP45-UD3P | G.Skill 2x2GB DDR2 1000 | XFX HD5870

Need website help? PM me!
CrazeD is offline  
Old 05-22-2006, 06:36 PM   #5 (permalink)
True Techie
 
Join Date: Apr 2006
Posts: 158
Send a message via AIM to kaname
Default

I think it's your drivers also. Try driver cleaner and reinstall the drivers for your radeon

http://www.drivercleaner.net/
__________________
EVGA 680i SLi
E6400 @ 3.0 GHz
4 GB OCZ Platinum Rev. 2 EL @ 880
400GB + 250GB Seagate Barracuda SATA2
EVGA 8800GTs
Antec P180B Case
kaname is offline  
Old 05-23-2006, 03:36 AM   #6 (permalink)
Newb Techie
 
Join Date: May 2006
Posts: 9
Default

Hmm... problemo... I've lost the driver disc.... can I download them off the net?
Renegade222 is offline  
Old 05-23-2006, 06:02 AM   #7 (permalink)
Lord Techie
 
Nitestick's Avatar
 
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473
Default

the card is artifacting, most likely it is on its last legs. i have seen virtually identical artifacting on an x600 that had been doused by a dodgy water cooling unit

edit: or it could just be overheating, not sure why i didn't mention that straight away.
Nitestick is offline  
Old 05-23-2006, 07:50 AM   #8 (permalink)
Monster Techie
 
FlashDude's Avatar
 
Join Date: Apr 2006
Location: NB, Canada
Posts: 1,232
Send a message via MSN to FlashDude
Default

I agree with nitestick the cards about to die, Yes go to ati and download the latest drivers and install them after you use a driver cleaner. (you will need .net frameworks to install the latest drivers). And make sure you have directX 9.0c.


Driver Cleaner

Direct X

ATI Drivers

If that doesn't work go back to your 5200
__________________
FlashDude is offline  
Old 05-23-2006, 08:04 AM   #9 (permalink)
Wizard Techie
 
CrazeD's Avatar
 
Join Date: Feb 2006
Location: Maine
Posts: 3,736
Send a message via AIM to CrazeD Send a message via MSN to CrazeD
Default

Quote:
Originally posted by FlashDude
I agree with nitestick the cards about to die, Yes go to ati and download the latest drivers and install them after you use a driver cleaner. (you will need .net frameworks to install the latest drivers). And make sure you have directX 9.0c.


Driver Cleaner

Direct X

ATI Drivers

If that doesn't work go back to your 5200
You only need the .net framework for catalyst control center, the drivers will still work without it.
__________________

Intel Q9400 | Gigabyte EP45-UD3P | G.Skill 2x2GB DDR2 1000 | XFX HD5870

Need website help? PM me!
CrazeD is offline  
Old 05-23-2006, 12:52 PM   #10 (permalink)
Master Techie
 
Join Date: Jun 2005
Posts: 2,134
Default

artifacting can look like that can it? never seen that before. i thought it was just coloured bits...
__________________

joshd is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.