No Video Display - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-16-2005, 07:41 PM   #1 (permalink)
Newb Techie
 
Join Date: Dec 2005
Posts: 1
Default No Video Display

Okay i was trouble shooting one of my machines when it dropped about 3 inches, the metal part of the video card bent and the card pulled out of the agp slot. There was no video when i put it back in. I installed another and still no video, i think i know but i hope its not wht i think it is, and i dont have spare motherboard handy. What do you guys think?

Thanks,
Mike
__________________

MikeShed is offline  
Old 12-16-2005, 07:43 PM   #2 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

you know exactly what we are going to say ( mobo )... unfortunately that is the only logical step to take. Good luck.
__________________

__________________
brady is offline  
Old 12-16-2005, 08:19 PM   #3 (permalink)
Monster Techie
 
Join Date: Sep 2005
Posts: 1,243
Send a message via AIM to CrAzY_GaMeR_07
Default

agree ^

unless you try a pci vid card :/
__________________
CrAzY_GaMeR_07 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.