No monitor signal with 5870 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-23-2009, 05:06 PM   #1 (permalink)
Wizard Techie
 
CrazeD's Avatar
 
Join Date: Feb 2006
Location: Maine
Posts: 3,736
Send a message via AIM to CrazeD Send a message via MSN to CrazeD
Default No monitor signal with 5870

So, about 3 weeks ago I got a PowerColor HD5870. Installed it, hooked up the 2x6 pin PCI-e, fired her up. No monitor signal. Turned it off, took it out, put it back, no monitor signal. Tried both DVI ports, nothing. Put old card back in, everything works.

So I figured it's DOA. Sent it back to Newegg. Yesterday I got refunded and overnighted an XFX HD5870. Installed it, blah blah, no monitor signal. Kay, wtf? Either I'm lucky enough to get two DOA in a row, or something isn't right here.

What the eff.

Also, once I put my old card back in and start up, it says that my overclocking has failed. I'm not sure what that's all about as my overclock has been stable for like a year. It did this on my first 5870 too, so I figured maybe my overclock was screwing me and reset CMOS...but that didn't help any.

Suggestions please. I'm getting very irritated.

EDIT:
Specs: AMD x2 4800+
MSI K9A Platinum
G.Skill 2x2GB DDR2 1000
PC Power & Cooling Silencer 610
__________________

__________________

Intel Q9400 | Gigabyte EP45-UD3P | G.Skill 2x2GB DDR2 1000 | XFX HD5870

Need website help? PM me!
CrazeD is offline  
Old 12-23-2009, 08:09 PM   #2 (permalink)
Monster Techie
 
meat_helmet's Avatar
 
Join Date: Apr 2006
Location: Sydney, Australia
Posts: 1,119
Default Re: No monitor signal with 5870

I would usual say 'it could be that your PSU is underpowered', but with a PC P&C 610w that just can't be the problem...

I know you have already tryed it, but sometimes re-seating it really firmly can work wonders. I've had some very strange problems in the past, from no signal to only using 1x express lane, and they have been fixed by a much more firm approach, lol. Sometimes it takes alot of force.
__________________

__________________
meat_helmet is offline  
Old 12-23-2009, 11:06 PM   #3 (permalink)
Lord Techie
 
hikaricloud's Avatar
 
Join Date: Jul 2005
Location: USA
Posts: 6,220
Default Re: No monitor signal with 5870

The "overclocking failing" doesn't have anything to do with your overclock actually failing, it's an error that sometimes pops up even on factory computers.

It sounds like some stray setting somewhere hates you. I don't know that board very well though, so I can't be of more help...otherwise it does sound like a power issue, even though your PSU should handle it fine.

I know it's a pain, but what you can try to do is unplug everything except the bare essentials and try the card, but it probably won't get you far.
__________________
R.I.P. Ronald C. "Bucky" Buck
3/13/1949 - 11/30/2010
Poizen22 - in all honesty id prefetr my pics get passed around then send perform some homo erotic sexual deed.
thirdshiftdj - what on earth are you trying to say???
I do not accept support questions via EMail, PM or IM.
If I helped you out, or what I just said rocked you like a hurricane, hit the little thingie over there.
<-------------------------------
hikaricloud is offline  
Old 12-23-2009, 11:42 PM   #4 (permalink)
Wizard Techie
 
CrazeD's Avatar
 
Join Date: Feb 2006
Location: Maine
Posts: 3,736
Send a message via AIM to CrazeD Send a message via MSN to CrazeD
Default Re: No monitor signal with 5870

I did try unplugging everything. I even tried using the molex to PCIe adapter things, on a whim.

I've reseated the card several times and it is indeed firmly seated. I tried alternating sticks of RAM. Tried resetting CMOS.

I tried to test it in my dad's PC but...it doesn't fit in his case! Frigin huge card...

I'm pretty sure I'm getting a new cpu+mobo for christmas. So, if it doesn't work then, I guess I'll be sending back ANOTHER doa card. So far these 5870's are really somethin...
__________________

Intel Q9400 | Gigabyte EP45-UD3P | G.Skill 2x2GB DDR2 1000 | XFX HD5870

Need website help? PM me!
CrazeD is offline  
Old 03-10-2010, 11:12 AM   #5 (permalink)
Newb Techie
 
Join Date: Mar 2010
Posts: 1
Default Re: No monitor signal with 5870

Quote:
Originally Posted by CrazeD View Post
So, about 3 weeks ago I got a PowerColor HD5870. Installed it, hooked up the 2x6 pin PCI-e, fired her up. No monitor signal. Turned it off, took it out, put it back, no monitor signal. Tried both DVI ports, nothing. Put old card back in, everything works.

So I figured it's DOA. Sent it back to Newegg. Yesterday I got refunded and overnighted an XFX HD5870. Installed it, blah blah, no monitor signal. Kay, wtf? Either I'm lucky enough to get two DOA in a row, or something isn't right here.

What the eff.

Also, once I put my old card back in and start up, it says that my overclocking has failed. I'm not sure what that's all about as my overclock has been stable for like a year. It did this on my first 5870 too, so I figured maybe my overclock was screwing me and reset CMOS...but that didn't help any.

Suggestions please. I'm getting very irritated.

EDIT:
Specs: AMD x2 4800+
MSI K9A Platinum
G.Skill 2x2GB DDR2 1000
PC Power & Cooling Silencer 610

After googling, this post popped up... I know this post is a few months old, but I just bought the same grafix card, and I have the very same problem.

So I was wondering if you found a solution to your problem? (since your specs says that you still have the same card)

Hope to hear from you
elmadmax is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official 5870 Review/Discussion Thread!!!! gurusan New Technology and Products 65 09-30-2009 06:02 PM
AMD ATi Radeon HD 5870 X2 Spotted Osiris New Technology and Products 6 09-26-2009 02:57 AM
AMD ATI Radeon HD 5870 Video Card Review Osiris New Technology and Products 1 09-23-2009 01:00 PM
5870 Details. philbar71 New Technology and Products 6 09-10-2009 01:38 PM
Radeon HD 5870 Specs Revealed Wildside New Technology and Products 38 07-15-2009 10:33 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.