New video card installed, lost sound... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 05-04-2009, 06:47 PM   #1 (permalink)
Newb Techie
Join Date: May 2009
Posts: 1
Default New video card installed, lost sound...

hello all,

i just installed a new graphics card (Radeon 4770HD), everything seemed to work fine except when i loaded HL2 and then Winamp. Winamp's error was specifically: 'bad sound driver...,' but both were on the same lines... no sound.

my previous card was old. a Radeon X300 series. it was included w/ the comp. when i purchased it some 5 years ago.

is it possible that the sound and the video were coming from the same card? i was under the impression sound could come from the mobo or a sound card. i sort of remember the video card and sound being called, 'integrated,' when i purchased the cpu though. either way, i do not get sound when i turn on my cpu so i know something is wrong.

can anyone assist?

let me know if you need more info to help.

thanks guys,


eidt: just check and i am not currently plugging my speakers into an expansion port so that leads me to believe the sound is integrated on the mobo. i just need to install new drivers. do i install new mb drivers though?

here is the image i see under sound:


funkygreenthing is offline  
Old 05-07-2009, 10:06 PM   #2 (permalink)
Monster Techie
sPlAtOiD's Avatar
Join Date: Nov 2002
Posts: 1,748
Default Re: New video card installed, lost sound...

Some more info would help. If this is a store bought computer just go to the maker web site look for support drivers and input your make of computer and look in the drivers section for sound driver.If this is a homemade computer find the name on the motherboard and go to the board maker site and do the same thing. After you get the drivers uninstall the old drivers in control panel,system,hardware.

sPlAtOiD is offline  
Old 05-07-2009, 11:57 PM   #3 (permalink)
Lord Techie
S0ULphIRE's Avatar
Join Date: Mar 2007
Location: Australia
Posts: 8,050
Send a message via MSN to S0ULphIRE
Default Re: New video card installed, lost sound...

Post up your Motherboard model number and I'll find the drivers for you.
"As a result of all this hardship, dirt, thirst, and wombats, you would expect Australians to be a sour lot. Instead, they are genial, jolly, cheerful, and always willing to share a kind word with a stranger, unless they are an American." -- Douglas Adams
S0ULphIRE is offline  
Old 05-08-2009, 12:33 AM   #4 (permalink)
Lord Techie
Hefemeister's Avatar
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: New video card installed, lost sound...

I would check what your default playback device is. The vid card you go has the ability to use hdmi and send audio that way as well. It probably has that set at default playback and the correct drivers were not installed. If you want to use your old sound set it as default playback device in sound properties.
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft Visual c++ error GG1972 Hardware Repairs and Troubleshooting 3 02-13-2009 09:52 PM
Video Card Issues kira987 Hardware Repairs and Troubleshooting 1 06-21-2008 09:07 PM
Gaming sound card and headset? jordo_99 New Systems | Building and Buying 16 04-18-2008 07:16 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.