new computer build not working, please help! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-27-2009, 11:46 AM   #1 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 26
Default new computer build not working, please help!

i recently built a whole new computer. bought all the parts from newegg.com and after some problems with ups, i finally got ALL my parts in yesterday. for some reason they shipped the case seperately from all the other components. but thats aside the point. after some small hassles, i finally got everything in place and everything seemed ready to go so i decided to plug the power into it real quick just to see if all the fans were working and all the power connections were right. here is where i think i royally screwed myself.

i had the power chord plugged into the wall first, and i also had the power switch in the PSU set to the ON position. i dont know why i didnt think of it, i should have, but for some reason i didnt think to turn off the switch before i plugged the power into it.
but as soon as the power chord from the wall came into contact with the power prongs in the PSU, i saw a spark come out somewhere. im not sure where it was in my computer, i only saw a flash of light out of the corner of my eye. now i didnt think anything of it at the time because everything seemed to be working fine. all fans working and all lights working.

now when i plugged it up to a monitor and keyboard and mouse, and everything else, nothing comes up on the screen. the monitor doesn't wake up. its like its not reading the computer turning on.

here is my build:

Newegg.com - ARK 6099-CA Black Steel ATX Mid Tower Computer Case 400W Power Supply - Computer Cases

Newegg.com - EVGA 512-P3-N975-AR GeForce 9800 GT 512MB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Supported Video Card - Desktop Graphics / Video Cards

Newegg.com - Seagate Barracuda 7200.10 ST380815AS 80GB 7200 RPM 8MB Cache SATA 3.0Gb/s Hard Drive - Internal Hard Drives

Newegg.com - ASUS P5Q LGA 775 Intel P45 ATX Intel Motherboard - Intel Motherboards

Newegg.com - Intel Core 2 Duo E7300 Wolfdale 2.66GHz 3MB L2 Cache LGA 775 Dual-Core Processor - Processors - Desktops

Newegg.com - Kingston 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory - Desktop Memory

Newegg.com - hec X-Power Pro 600 600W Continuous @ 40°C ATX12V V2.2 SLI Ready CrossFire Ready Power Supply - Power Supplies

like i said everything powers up, but nothing happens when i boot it up. possibly i fried something? if so then why would everything power up and run fine?
any other information needed to find out the problem please ask, and thanks in advance to anyone who can help with this.
__________________

saucy2040 is offline  
Old 01-27-2009, 11:55 AM   #2 (permalink)
Super Techie
 
Join Date: Jul 2007
Location: MN, USA
Posts: 341
Default Re: new computer build not working, please help!

Do you hear any series of beeps? Can you hear if it goes beyond POST.
__________________

__________________
D-Rocks is offline  
Old 01-27-2009, 12:05 PM   #3 (permalink)
Master Techie
 
NightSurge's Avatar
 
Join Date: Feb 2008
Location: Fort Wayne, IN
Posts: 2,217
Send a message via AIM to NightSurge
Default Re: new computer build not working, please help!

Try using just one stick of RAM at a time. Could be a bad RAM situation which is very common
__________________

If I was helpful, please click the icon on the left hand side of this message that looks like a check mark Thanks!

NightSurge is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
POST Troubleshooting Guide SYL\X/3K Hardware Repairs and Troubleshooting 7 03-07-2009 11:24 AM
Pentium 3 computer, hard drive not working farmer2009 Hardware Repairs and Troubleshooting 9 11-06-2008 08:44 AM
Newbie needs a $600 computer build, please kevin2041 System Upgrades 2 08-20-2008 07:42 PM
A Computer Building Guide.....by Elbatrop1 Elbatrop1 System Upgrades 31 04-07-2007 08:26 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.