My PC that i build wont turn on HELP? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-02-2012, 05:59 PM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2012
Posts: 3
Default My PC that i build wont turn on HELP?

Hello,
First time i used this forum but i need help. I bought parts from overclockers.co.uk 2 weeks ago and after them forgetting to send out my powersupply i got it today and put it in. When i pressed the power button Notting happen. There are no lights on the motherboard at all and Notting turns on at all. All i can tell you is that powersupply lead has power and when i turn on powersupply button at the back of the pc i can hear a noise that sound like spark or something that means there power. My freind looked over everything for like two hours and cant find a problem, i know it can be hardware fault but i need to try and see is there any other problem help please anyone?

my PC SPEC:
MSI GeForce GTX 570 OC Twin FrozR III Power Edition 1280MB GDDR5 PCI-Express Graphics Card
XFX 850W XXX Edition Modular '80 Plus Silver' Power Supply
Western Digital Caviar Blue 500GB SATA 6Gbs 16MB Cache - OEM
Kingston HyperX Genesis Grey 8GB (2x4GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit
Samsung SH-S222ABRSMS 22x DVD±RW SATA ReWriter (BlackSilverBiege)
Phobya Nano-G 14 Silent Waterproof 1000rpm 140mm Fan
Asrock Z68 Extreme4 Gen3 Intel Z68 (Socket 1155) DDR3 Motherboard
Intel Core i5-2500K 3.30GHz (Sandybridge) Socket LGA1155 Processor
__________________

seanireland is offline  
Old 03-02-2012, 07:43 PM   #2 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: My PC that i build wont turn on HELP?

If it's sparking, that can be a big problem. Do you have any other PSU around? I would try a different one just to check.
__________________

__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 03-02-2012, 07:44 PM   #3 (permalink)
Newb Techie
 
Join Date: Mar 2012
Posts: 3
Default Re: My PC that i build wont turn on HELP?

its not sparking really, i just did not use the best words to describe it, its makes a noise that you know that there power in the power supply button
seanireland is offline  
Old 03-02-2012, 07:47 PM   #4 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: My PC that i build wont turn on HELP?

Did you connect the 8-pin and 6-pin PCI-e?

Try reseating your RAM.

Is it plugged in?
__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 03-02-2012, 07:48 PM   #5 (permalink)
Newb Techie
 
Join Date: Mar 2012
Posts: 3
Default Re: My PC that i build wont turn on HELP?

resetting ram ?? how i do that, would that cause it to have no lights on the motherboard at all, and yes i have it plugged in and plug has power
seanireland is offline  
Old 03-02-2012, 09:20 PM   #6 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: My PC that i build wont turn on HELP?

Take the RAM out, put back in. Could be a connection issue.
__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 03-05-2012, 12:18 AM   #7 (permalink)
Lord of Bacon
 
Roark's Avatar
 
Join Date: Apr 2011
Location: North Carolina
Posts: 1,352
Default Re: My PC that i build wont turn on HELP?

Quote:
Originally Posted by MondoverMaster
Did you connect the 8-pin
If you're looking for easy fixes:
Is the switch on the back of the PSU on I and not O? (or is it 1 not 0?)
__________________
Please read through the thread thoroughly before responding.
Nobody wants to read a wall of text, formatting is your friend.

i5 3570k | 8GB G.Skill 1600MHz | R9 290 | SeaSonic 750X
Roark is offline  
Old 03-06-2012, 09:12 AM   #8 (permalink)
OCZ SSD Enthusiast
 
Night Fox's Avatar
 
Join Date: Dec 2009
Location: Michigan
Posts: 656
Default Re: My PC that i build wont turn on HELP?

This video shows you how to double check that your power supply works (particularly the motherboard connector). Or if you prefer text and pictures: How To: Jump Start A Power Supply (PSU) / Test A Power Supply And Components But make sure you put the paperclip in the correct pins (note: I do not know what happens if you use the wrong pins...so don't mess up :P ). Alternatively, you could just plug a fan with a molex connector into the PSU and make sure it runs.

Other than that, I'd just make sure all cables are plugged in correctly, and if the light on the motherboard doesn't turn on...then your best bet is to RMA the motherboard in my opinion.
__________________
Asus P5Q Motherboard * OC'ed Intel Core2 Quad Q9400 2.82ghz w/ Arctic Silver 5 * OCZ Platinum 4GB (2 x 2GB) DDR2 1066ghz * Kingston Hyper X (2x2gb) DDR2 1066ghz * EVGA GTX 560 Ti Superclocked * Ultra X-Blaster ATX Mid-Tower * OCZ Vertex 2 120gb * WD Caviar Blue 500GB 7200 rpm * OCZ ModXStream Pro 700W Modular PSU * Sony Optaric DVD Burner * Windows 7 Home Premium 64-bit * 22" LG Flatron W2252TQ LCD * LG Flatron E2281

Samsung Series 7 17.3" Laptop w/ 256gb Vertex 4 SSD
Night Fox is offline  
Old 03-10-2012, 10:12 AM   #9 (permalink)
Newb Techie
 
Join Date: Mar 2012
Posts: 2
Default Re: My PC that i build wont turn on HELP?

I had the same problem first with my new (and first own) build, but it turned out I had plugged the small cable from the chassis power on button incorrectly to the motherboard, so I would check that. Referring to the motherboard manual shows the correct way to connect power on button, power on led etc. cables.
Kurimus is offline  
Old 03-10-2012, 02:15 PM   #10 (permalink)
The Residential Loon
 
Spud1200's Avatar
 
Join Date: Nov 2010
Location: England, UK
Posts: 2,090
Default Re: My PC that i build wont turn on HELP?

Hopefully you have Solved this problem by now but if you have not, you need to do some Fault Finding. Check that the PSU Unit is Turned on via the back and set at I in order to give the Unit Power, you need to make sure you have the Headers on the Motherbord set correctly as in Power to Power, HDD to HDD, Reset Swich to Reset Swich, from the acutall Case you have for your Build.

My Advice is that you purchase a PSU Tester, in order to check the Unit is working ok, I have one here at Home and it will State the Voltage of the Rails in the Unit and will state if "Good" or "Bad", via Green or Red LEDs.

If the Unit is connected to the Motherbord via the 24 Pin Power Surply, even if you connect a Visual source for the pourpus of being able to see the Bair Bones of the System Working, that would be a good thing, concidering you have a output to you Screen.

Install the Cpu, Heatsink and Fan, Memory, and PSU, then Connect a Monitor thus checking its working fine. Start off with one Stick, and Install the Rest if all goes well.
__________________

Spud1200 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new build wont turn off chris187 Hardware Repairs and Troubleshooting 2 08-30-2007 08:39 PM
pc wont turn on cloud Hardware Repairs and Troubleshooting 9 07-08-2007 06:46 PM
Wont Turn Off? jcortes Hardware Repairs and Troubleshooting 9 11-30-2006 12:46 AM
pc wont turn on drumerdudeman Hardware Repairs and Troubleshooting 9 03-07-2006 01:34 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.