My new build will not turn on!!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 03-05-2009, 12:07 AM   #1 (permalink)
Newb Techie
Join Date: Mar 2009
Location: Texas
Posts: 4
Question My new build will not turn on!!!

Hi, I am building my first computer and I an have some difficulties. I got all of my parts and i put everything together but when I turn it on, nothing happens. I dont know why. Everything is new but the hard drive and everything is pluged up.
If anyone could help me it would be very much apriciated. I have put $800 into this so far and i dont want it to go to waste.

necrogasm is offline  
Old 03-05-2009, 02:29 AM   #2 (permalink)
Junior Techie
Join Date: Jan 2009
Location: Melbourne, Australia
Posts: 54
Default Re: My new build will not turn on!!!

what are the specs..?

skiki is offline  
Old 03-05-2009, 03:23 AM   #3 (permalink)
The Almighty Forensica
Yami's Avatar
Join Date: Dec 2008
Location: UK
Posts: 7,429
Default Re: My new build will not turn on!!!

What are the specs, and have do you have the power button plugged in correctly?
Desktop i5-4440 - ASRock Z77 Extreme4 - EVGA GTX970 - 4x4GB 1600MHz - Samsung 850 EVO 250GB - Be Silent Base 800 - 3TB+1TB+640GB
Laptop i7-3740QM @ 2.7GHz, 2x4GB 1600Mhz, GT640M, OCZ Agility 3 120GB
Smartphone HTC One M8 - Sense 7 - 6.0

Uni MSci Ethical Hacking, Coventry University
Work Trainee Cell Site Analyst
LinkedIn Kiera Mitchell
Yami is offline  
Old 03-05-2009, 03:42 AM   #4 (permalink)
Monster Techie
TheHumanComputer's Avatar
Join Date: Feb 2009
Location: Inside A P c
Posts: 1,181
Default Re: My new build will not turn on!!!

are you sure u plugged the power switch in right on the mobo? you might have put it in the round way around
AMD FX 9370 @ 4.4Ghz
Asus Crosshair V Formula Z
Deepcool Genome Case with Watercooling
16GB DDR3 1600Mhz
Areocool 750W Semi Modular PSU
TheHumanComputer is offline  
Old 03-05-2009, 03:49 AM   #5 (permalink)
True Techie
Join Date: Feb 2007
Posts: 150
Default Re: My new build will not turn on!!!

yeah, make sure you plugged the power button in, it is usually one of the cords hanging from the front of your PC inside....i forgot the color if there is a usual one.

look at the specs for your mobo and figure out where it is located (usually on the bottom) and plug it in

next, make sure everything from your PSU is put in correctly...make sure your PSU is plugged sorry if you think we are treating you like an idiot or w.e but there are some very simply steps
RogueSeven is offline  
Old 03-05-2009, 09:41 AM   #6 (permalink)
True Techie
Join Date: Jan 2009
Posts: 107
Default Re: My new build will not turn on!!!

also, make sure the I/O switch on the back of the power supply is ON, not off.
delirium330 is offline  
Old 03-05-2009, 06:31 PM   #7 (permalink)
Ultra Techie
Join Date: Jun 2008
Posts: 548
Default Re: My new build will not turn on!!!

I sooo did that with mine and nearly had a panic attack, but remembered "oh wait, this is a NEW PSU, I bet it has a switch in the back!" flipped it and zomgzor didn't know the mobo had a bright WHITE light. lol.
Gothch1ck is offline  
Old 03-05-2009, 07:40 PM   #8 (permalink)
Lord Techie
veedubfreak's Avatar
Join Date: Jul 2007
Posts: 6,979
Default Re: My new build will not turn on!!!

Do you have any lights on the motherboard? Almost all new boards these days have a light indicating they are getting power. If it is, that leads to either the power button not being plugged in, or plugged in backwards or possibly a bad power supply.
Nothing to see here.
veedubfreak is offline  
Old 03-10-2009, 10:23 AM   #9 (permalink)
Newb Techie
Join Date: Mar 2009
Location: Texas
Posts: 4
Default Re: My new build will not turn on!!!

My specs are:
Core2 quad Q9550 2.8GHz
680i mobo
650W psu
2GBs of RAM
and an old 80GB hard drive

I found That my problem was that i had not pluged up the CPU fan. After that I found out that my mobo had a short, so I got a new one.

When it came in I hooked everything up and now when I turn it on a blue light comes on the corner of the motherboard and the fans will run for like 5 seconds, then it will shut off. Nothing ever shows on the monitor. Is it my graphics card maybe?
necrogasm is offline  
Old 03-10-2009, 11:03 AM   #10 (permalink)
Newb Techie
Join Date: Mar 2009
Location: Sunny Wales!
Posts: 7
Default Re: My new build will not turn on!!!

Hey, i have pretty much the exact same setup, but with 4gb Of ram...and i had exact same problem, after changing the GFX Card, PSU , Motherboard, it was the ram slots. Some mobo's are fussy on which configuration You use. If you'r using two seperate Modules of ram, take one out, and try the one stick in each slot, and post back

Hope this helps. !

Danarchy is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
New build givin me problems MattW Hardware Repairs and Troubleshooting 6 08-17-2008 05:14 AM
Rate this build, PC under $800 Lobstar System Upgrades 4 08-07-2008 11:22 AM
my computer build!!! hitmanj New Systems | Building and Buying 50 06-29-2008 11:44 AM
4870 Build elateral New Systems | Building and Buying 19 06-25-2008 07:10 PM
new build wont turn off chris187 Hardware Repairs and Troubleshooting 2 08-30-2007 07:39 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.