Mouse Problem? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 05-18-2006, 02:48 PM   #1 (permalink)
Join Date: Mar 2006
Posts: 154
Default Mouse Problem?

Hey everyone, this has been going on for awhile and Im getting sick of it. Sometimes I will be moving my mouse acroos the screen to an icon or anything and it will studder or stop. Then I will have to wiggle my mouse to get it back to normal. This really annoys me, especially on games. My game isn't lagging its just that my mouse wont turn smooth and stuff. I thought it might be my HDD so I defragmented, ran CCleaner, virus scan, spyware scan, registry scan, everything and it still does it. I am using a wireless mouse at the moment. Would any of you know what the problem is? Thanks

fuz_master is offline  
Old 05-18-2006, 03:52 PM   #2 (permalink)
Join Date: Mar 2006
Posts: 154

Can someoe help me please?
fuz_master is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.